aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-navman_2.6.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-navman_2.6.18.bb')
-rw-r--r--recipes/linux/linux-navman_2.6.18.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/linux/linux-navman_2.6.18.bb b/recipes/linux/linux-navman_2.6.18.bb
new file mode 100644
index 0000000000..b37b68e8c9
--- /dev/null
+++ b/recipes/linux/linux-navman_2.6.18.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Linux Kernel for Cirrus Logic ep39xx compatible machines"
+SECTION = "kernel"
+LICENSE = "GPL"
+
+#DEPENDS = "u-boot"
+
+PR = "r0"
+
+COMPATIBLE_MACHINE = "navman-icn330"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2 \
+ http://www.duff.dk/navman/navman-2.6.18.patch;patch=1 \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/linux-2.6.18"
+
+inherit kernel
+
+
+do_configure() {
+ rm -f ${S}/.config
+
+ if [ ! -e ${WORKDIR}/defconfig ]; then
+ die "No default configuration for ${MACHINE} available."
+ fi
+
+
+ if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibcgnueabi" ]; then
+ echo "CONFIG_AEABI=y" >> ${S}/.config
+ echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
+ else
+ echo "# CONFIG_AEABI is not set" >> ${S}/.config
+ echo "# CONFIG_OABI_COMPAT is not set" >> ${S}/.config
+ fi
+
+ sed -e '/CONFIG_AEABI/d' \
+ -e '/CONFIG_OABI_COMPAT=/d' \
+ '${WORKDIR}/defconfig' >>'${S}/.config'
+
+ yes '' | oe_runmake oldconfig
+}