aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-omap_2.6.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-omap_2.6.29.bb')
-rw-r--r--recipes/linux/linux-omap_2.6.29.bb70
1 files changed, 68 insertions, 2 deletions
diff --git a/recipes/linux/linux-omap_2.6.29.bb b/recipes/linux/linux-omap_2.6.29.bb
index a2391ee522..6300e0d708 100644
--- a/recipes/linux/linux-omap_2.6.29.bb
+++ b/recipes/linux/linux-omap_2.6.29.bb
@@ -10,7 +10,7 @@ DEFAULT_PREFERENCE_overo = "1"
SRCREV = "58cf2f1425abfd3a449f9fe985e48be2d2555022"
-PR = "r7+gitr${SRCREV}"
+PR_append = "+gitr${SRCREV}"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
file://defconfig"
@@ -20,7 +20,19 @@ SRC_URI_append = " \
file://no-cortex-deadlock.patch;patch=1 \
file://read_die_ids.patch;patch=1 \
file://fix-install.patch;patch=1 \
- file://DSS2.diff;patch=1 \
+ file://dss2/0001-Revert-gro-Fix-legacy-path-napi_complete-crash.patch;patch=1 \
+ file://dss2/0002-OMAPFB-move-omapfb.h-to-include-linux.patch;patch=1 \
+ file://dss2/0003-DSS2-OMAP2-3-Display-Subsystem-driver.patch;patch=1 \
+ file://dss2/0004-DSS2-OMAP-framebuffer-driver.patch;patch=1 \
+ file://dss2/0005-DSS2-Add-panel-drivers.patch;patch=1 \
+ file://dss2/0006-DSS2-HACK-Add-DSS2-support-for-N800.patch;patch=1 \
+ file://dss2/0007-DSS2-Add-DSS2-support-for-SDP-Beagle-Overo-EVM.patch;patch=1 \
+ file://dss2/0008-DSS2-Add-function-to-display-object-to-get-the-back.patch;patch=1 \
+ file://dss2/0009-DSS2-Add-acx565akm-panel.patch;patch=1 \
+ file://dss2/0010-DSS2-Small-VRFB-context-allocation-bug-fixed.patch;patch=1 \
+ file://dss2/0011-DSS2-Allocated-memory-for-Color-Look-up-table.patch;patch=1 \
+ file://dss2/0012-DSS2-Fix-DMA-rotation.patch;patch=1 \
+ file://dss2/0013-DSS2-Verify-that-overlay-paddr-0.patch;patch=1 \
file://0001-board-ldp-add-regulator-info-to-get-the-microSD-slo.patch;patch=1 \
file://fix-unaligned-access.diff;patch=1 \
file://make-alignment-visible.diff;patch=1 \
@@ -28,6 +40,60 @@ SRC_URI_append = " \
file://ehci.patch;patch=1 \
file://fix-audio-capture.patch;patch=1 \
file://ads7846-detection.patch;patch=1 \
+ file://musb/0001-USB-musb-only-turn-off-vbus-in-OTG-hosts.patch;patch=1 \
+ file://musb/0002-USB-composite-avoid-inconsistent-lock-state.patch;patch=1 \
+ file://musb/0003-USB-musb-NAK-timeout-scheme-on-bulk-RX-endpoint.patch;patch=1 \
+ file://musb/0004-USB-musb-rewrite-host-periodic-endpoint-allocation.patch;patch=1 \
+ file://musb/0005-USB-TWL-disable-VUSB-regulators-when-cable-unplugg.patch;patch=1 \
+ file://musb/0006-USB-gadget-composite-device-level-suspend-resume-h.patch;patch=1 \
+ file://musb/0007-usb-gadget-fix-ethernet-link-reports-to-ethtool.patch;patch=1 \
+ file://musb/0008-usb-musb_host-minor-enqueue-locking-fix-v2.patch;patch=1 \
+ file://musb/0009-usb-musb_host-fix-ep0-fifo-flushing.patch;patch=1 \
+ file://musb/0010-musb-sanitize-clearing-TXCSR-DMA-bits-take-2.patch;patch=1 \
+ file://musb/0011-musb-fix-isochronous-TXDMA-take-2.patch;patch=1 \
+ file://musb/0012-musb-fix-possible-panic-while-resuming.patch;patch=1 \
+ file://musb/0013-musb_host-refactor-musb_save_toggle-take-2.patch;patch=1 \
+ file://musb/0014-musb_gadget-suppress-parasitic-TX-interrupts-with.patch;patch=1 \
+ file://musb/0015-musb_gadget-fix-unhandled-endpoint-0-IRQs.patch;patch=1 \
+ file://musb/0016-musb_host-factor-out-musb_ep_-get-set-_qh.patch;patch=1 \
+ file://musb/0017-musb_host-refactor-URB-giveback.patch;patch=1 \
+ file://musb/0018-musb-split-out-CPPI-interrupt-handler.patch;patch=1 \
+ file://musb/0019-musb_host-simplify-check-for-active-URB.patch;patch=1 \
+ file://musb/0020-musb_host-streamline-musb_cleanup_urb-calls.patch;patch=1 \
+ file://musb/0021-twl4030-usb-fix-minor-reporting-goofage.patch;patch=1 \
+ file://musb/0022-musb-use-dma-mode-1-for-TX-if-transfer-size-equals.patch;patch=1 \
+ file://musb/0023-musb-add-high-bandwidth-ISO-support.patch;patch=1 \
+ file://musb/0024-USB-otg-adding-nop-usb-transceiver.patch;patch=1 \
+ file://musb/0025-nop-usb-xceiv-behave-when-linked-as-a-module.patch;patch=1 \
+ file://musb/0026-musb-proper-hookup-to-transceiver-drivers.patch;patch=1 \
+ file://musb/0027-musb-otg-timer-cleanup.patch;patch=1 \
+ file://musb/0028-musb-make-initial-HNP-roleswitch-work-v2.patch;patch=1 \
+ file://musb/0029-musb-support-disconnect-after-HNP-roleswitch.patch;patch=1 \
+ file://isp/v4l/0001-V4L2-Add-COLORFX-user-control.patch;patch=1 \
+ file://isp/v4l/0002-V4L-Int-if-v4l2_int_device_try_attach_all-requires.patch;patch=1 \
+ file://isp/v4l/0003-V4L-Int-if-Dummy-slave.patch;patch=1 \
+ file://isp/v4l/0004-V4L-int-device-add-support-for-VIDIOC_QUERYMENU.patch;patch=1 \
+ file://isp/v4l/0005-V4L-Int-if-Add-vidioc_int_querycap.patch;patch=1 \
+ file://isp/iommu/0001-omap-iommu-tlb-and-pagetable-primitives.patch;patch=1 \
+ file://isp/iommu/0002-omap-iommu-omap2-architecture-specific-functions.patch;patch=1 \
+ file://isp/iommu/0003-omap-iommu-omap3-iommu-device-registration.patch;patch=1 \
+ file://isp/iommu/0004-omap-iommu-simple-virtual-address-space-management.patch;patch=1 \
+ file://isp/iommu/0005-omap-iommu-entries-for-Kconfig-and-Makefile.patch;patch=1 \
+ file://isp/iommu/0006-omap-iommu-Don-t-try-BUG_ON-in_interrupt.patch;patch=1 \
+ file://isp/iommu/0007-omap-iommu-We-support-chained-scatterlists-probabl.patch;patch=1 \
+ file://isp/iommu/0008-omap2-iommu-entries-for-Kconfig-and-Makefile.patch;patch=1 \
+ file://isp/omap3camera/0001-omap3isp-Add-ISP-main-driver-and-register-definitio.patch;patch=1 \
+ file://isp/omap3camera/0002-omap3isp-Add-ISP-MMU-wrapper.patch;patch=1 \
+ file://isp/omap3camera/0003-omap3isp-Add-userspace-header.patch;patch=1 \
+ file://isp/omap3camera/0004-omap3isp-Add-ISP-frontend-CCDC.patch;patch=1 \
+ file://isp/omap3camera/0005-omap3isp-Add-ISP-backend-PRV-and-RSZ.patch;patch=1 \
+ file://isp/omap3camera/0006-omap3isp-Add-statistics-collection-modules-H3A-and.patch;patch=1 \
+ file://isp/omap3camera/0007-omap3isp-Add-CSI2-interface-support.patch;patch=1 \
+ file://isp/omap3camera/0008-omap3isp-Add-ISP-tables.patch;patch=1 \
+ file://isp/omap3camera/0009-omap34xxcam-Add-camera-driver.patch;patch=1 \
+# file://isp/base/0001-omap3-Add-base-address-definitions-and-resources-fo.patch;patch=1 \
+# file://isp/standalone/0001-Resizer-and-Previewer-driver-added-to-commit.patch;patch=1 \
+# file://isp/standalone/0002-Resizer-bug-fixes-on-top-of-1.0.2-release.patch;patch=1 \
"