aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-omap_2.6.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-omap_2.6.29.bb')
-rw-r--r--recipes/linux/linux-omap_2.6.29.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap_2.6.29.bb b/recipes/linux/linux-omap_2.6.29.bb
new file mode 100644
index 0000000000..6e824b08db
--- /dev/null
+++ b/recipes/linux/linux-omap_2.6.29.bb
@@ -0,0 +1,40 @@
+require linux.inc
+
+DESCRIPTION = "Linux kernel for OMAP processors"
+KERNEL_IMAGETYPE = "uImage"
+
+COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo"
+
+# This is missing the EHCI patch for beagle
+DEFAULT_PREFERENCE = "-1"
+
+SRCREV = "90e758af52ba803cba233fabee81176d99589f09"
+
+PV = "2.6.29-${PR}+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
+ file://defconfig"
+
+SRC_URI_append = " \
+ file://no-empty-flash-warnings.patch;patch=1 \
+ file://no-cortex-deadlock.patch;patch=1 \
+ file://read_die_ids.patch;patch=1 \
+ file://fix-install.patch;patch=1 \
+ file://DSS2.diff;patch=1 \
+"
+
+
+SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \
+ "
+
+SRC_URI_append_omap3evm = " \
+ file://evm-mcspi-ts.diff;patch=1 \
+"
+
+S = "${WORKDIR}/git"
+
+
+module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
+
+