aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-openmoko-2.6.24/0003-squashfs-force-O2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-openmoko-2.6.24/0003-squashfs-force-O2.patch')
-rw-r--r--recipes/linux/linux-openmoko-2.6.24/0003-squashfs-force-O2.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.24/0003-squashfs-force-O2.patch b/recipes/linux/linux-openmoko-2.6.24/0003-squashfs-force-O2.patch
new file mode 100644
index 0000000000..550077b9fa
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.24/0003-squashfs-force-O2.patch
@@ -0,0 +1,17 @@
+The kernel patch from the squashfs-3.1r2 release did not compile on my
+armeb-linux-gcc 4.1.1 when optimizing for size (-Os). This works around
+that problem by using optimization flag -O2 instead for these two files.
+
+Signed-off-by: Leon Woestenberg <leonw@mailcan.com>
+
+Index: linux-2.6.19/fs/squashfs/Makefile
+===================================================================
+--- linux-2.6.19.orig/fs/squashfs/Makefile
++++ linux-2.6.19/fs/squashfs/Makefile
+@@ -5,3 +5,6 @@
+ obj-$(CONFIG_SQUASHFS) += squashfs.o
+ squashfs-y += inode.o
+ squashfs-y += squashfs2_0.o
++
++CFLAGS_squashfs2_0.o = "-O2"
++CFLAGS_inode.o = "-O2"