aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-tornado-omap2_2.6.16.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-tornado-omap2_2.6.16.16.bb')
-rw-r--r--recipes/linux/linux-tornado-omap2_2.6.16.16.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/linux/linux-tornado-omap2_2.6.16.16.bb b/recipes/linux/linux-tornado-omap2_2.6.16.16.bb
new file mode 100644
index 0000000000..a9ebee14cd
--- /dev/null
+++ b/recipes/linux/linux-tornado-omap2_2.6.16.16.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Linux kernel for HTC Tornado/Typhoon/Hurricane phones."
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
+ http://www.muru.com/linux/omap/patches/old/patch-2.6.16-omap2.bz2;patch=1 \
+ file://linux-2.6.16.16.patch;patch=1 \
+ file://tornado-20070320.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-2.6.16"
+
+inherit kernel
+
+COMPATIBLE_MACHINE = "htctornado"
+
+do_configure() {
+
+ rm -f ${S}/.config
+
+ if [ ! -e ${WORKDIR}/defconfig ]; then
+ die "No default configuration for ${MACHINE} available."
+ fi
+
+
+ if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibcgnueabi" ]; then
+ echo "CONFIG_AEABI=y" >> ${S}/.config
+ echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
+ else
+ echo "# CONFIG_AEABI is not set" >> ${S}/.config
+ echo "# CONFIG_OABI_COMPAT is not set" >> ${S}/.config
+ fi
+
+ sed -e '/CONFIG_AEABI/d' \
+ -e '/CONFIG_OABI_COMPAT=/d' \
+ '${WORKDIR}/defconfig' >>'${S}/.config'
+
+ yes '' | oe_runmake oldconfig
+
+}