summaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-wrt-2.4.20/160-expr.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-wrt-2.4.20/160-expr.patch')
-rw-r--r--recipes/linux/linux-wrt-2.4.20/160-expr.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes/linux/linux-wrt-2.4.20/160-expr.patch b/recipes/linux/linux-wrt-2.4.20/160-expr.patch
new file mode 100644
index 0000000000..f19fe24c6d
--- /dev/null
+++ b/recipes/linux/linux-wrt-2.4.20/160-expr.patch
@@ -0,0 +1,11 @@
+--- linux/Makefile 2004-08-16 21:31:21.850402752 -0400
++++ linux/Makefile 2004-08-16 21:48:22.372259848 -0400
+@@ -357,7 +357,7 @@
+ @rm -f .ver1
+
+ include/linux/version.h: ./Makefile
+- @expr length "$(KERNELRELEASE)" \<= $(uts_len) > /dev/null || \
++ @expr "$(KERNELRELEASE)" : '.*' \<= $(uts_len) > /dev/null || \
+ (echo KERNELRELEASE \"$(KERNELRELEASE)\" exceeds $(uts_len) characters >&2; false)
+ @echo \#define UTS_RELEASE \"$(KERNELRELEASE)\" > .ver
+ @echo \#define LINUX_VERSION_CODE `expr $(VERSION) \\* 65536 + $(PATCHLEVEL) \\* 256 + $(SUBLEVEL)` >> .ver