aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-wrt-2.4.20/nobcom.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-wrt-2.4.20/nobcom.patch')
-rw-r--r--recipes/linux/linux-wrt-2.4.20/nobcom.patch67
1 files changed, 67 insertions, 0 deletions
diff --git a/recipes/linux/linux-wrt-2.4.20/nobcom.patch b/recipes/linux/linux-wrt-2.4.20/nobcom.patch
new file mode 100644
index 0000000000..fab51de5b6
--- /dev/null
+++ b/recipes/linux/linux-wrt-2.4.20/nobcom.patch
@@ -0,0 +1,67 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- linux-2.4.20/drivers/net/Makefile~nobcom 2005-01-07 04:50:19.157885000 -0500
++++ linux-2.4.20/drivers/net/Makefile 2005-01-07 04:50:19.221875336 -0500
+@@ -23,7 +23,7 @@
+ ppp_mppe_c-objs := ppp_mppe_mppc_comp.o ppp_mppe_crypto.o
+
+ # subdir-m += mac
+-subdir-m += diag
++# subdir-m += diag
+
+ ifeq ($(CONFIG_HW_QOS),y)
+ subdir-m += port_based_qos
+@@ -270,28 +270,15 @@
+ ifdef CONFIG_HND
+ subdir-$(CONFIG_HND) += hnd
+ endif
+-ifdef CONFIG_ET
+-subdir-$(CONFIG_ET) += et.4702
+-subdir-$(CONFIG_ET) += et
+-endif
+ ifdef CONFIG_IL
+ subdir-$(CONFIG_IL) += il
+ endif
+-ifdef CONFIG_WL
+-subdir-$(CONFIG_WL) += wl
+-endif
+ ifeq ($(CONFIG_HND),y)
+ obj-y += hnd/hnd.o
+ endif
+-ifeq ($(CONFIG_ET),y)
+- obj-y += et/et.o
+-endif
+ ifeq ($(CONFIG_IL),y)
+ obj-y += il/il.o
+ endif
+-ifeq ($(CONFIG_WL),y)
+- obj-y += wl/wl.o
+-endif
+
+ include $(TOPDIR)/Rules.make
+
+--- linux-2.4.20/net/core/Makefile~nobcom 2005-01-07 04:49:30.581269000 -0500
++++ linux-2.4.20/net/core/Makefile 2005-01-07 04:50:19.221875336 -0500
+@@ -7,8 +7,7 @@
+ #
+ # Note 2! The CFLAGS definition is now in the main makefile...
+
+-SRCBASE := $(TOPDIR)/../..
+-EXTRA_CFLAGS += -Wall -I$(SRCBASE)/
++EXTRA_CFLAGS += -Wall
+ O_TARGET := core.o
+
+ export-objs := netfilter.o profile.o
+--- linux-2.4.20/arch/mips/config-shared.in~nobcom 2005-01-07 04:49:30.583269000 -0500
++++ linux-2.4.20/arch/mips/config-shared.in 2005-01-07 04:50:19.222875184 -0500
+@@ -543,7 +543,6 @@
+ define_bool CONFIG_NONCOHERENT_IO y
+ define_bool CONFIG_NEW_TIME_C y
+ define_bool CONFIG_NEW_IRQ y
+- define_bool CONFIG_HND y
+ fi
+ if [ "$CONFIG_SNI_RM200_PCI" = "y" ]; then
+ define_bool CONFIG_ARC32 y