aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/unslung-kernel/anonymiser.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/unslung-kernel/anonymiser.patch')
-rw-r--r--recipes/linux/unslung-kernel/anonymiser.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/linux/unslung-kernel/anonymiser.patch b/recipes/linux/unslung-kernel/anonymiser.patch
new file mode 100644
index 0000000000..61201031fa
--- /dev/null
+++ b/recipes/linux/unslung-kernel/anonymiser.patch
@@ -0,0 +1,24 @@
+--- linux-2.4.22/Makefile.orig 2004-12-26 13:11:25.000000000 +1030
++++ linux-2.4.22/Makefile 2004-12-26 13:12:32.000000000 +1030
+@@ -431,12 +431,15 @@
+ @LANG=C echo ' '`date` >> .ver1
+ @echo \#define UTS_VERSION \"`cat .ver1 | $(uts_truncate)`\" > .ver
+ @LANG=C echo \#define LINUX_COMPILE_TIME \"`date +%T`\" >> .ver
+- @echo \#define LINUX_COMPILE_BY \"`whoami`\" >> .ver
+- @echo \#define LINUX_COMPILE_HOST \"`hostname | $(uts_truncate)`\" >> .ver
+- @([ -x /bin/dnsdomainname ] && /bin/dnsdomainname > .ver1) || \
+- ([ -x /bin/domainname ] && /bin/domainname > .ver1) || \
+- echo > .ver1
+- @echo \#define LINUX_COMPILE_DOMAIN \"`cat .ver1 | $(uts_truncate)`\" >> .ver
++# @echo \#define LINUX_COMPILE_BY \"`whoami`\" >> .ver
++ @echo \#define LINUX_COMPILE_BY \"unslung\" >> .ver
++# @echo \#define LINUX_COMPILE_HOST \"`hostname | $(uts_truncate)`\" >> .ver
++ @echo \#define LINUX_COMPILE_HOST \"unslung.org\" >> .ver
++# @([ -x /bin/dnsdomainname ] && /bin/dnsdomainname > .ver1) || \
++# ([ -x /bin/domainname ] && /bin/domainname > .ver1) || \
++# echo > .ver1
++# @echo \#define LINUX_COMPILE_DOMAIN \"`cat .ver1 | $(uts_truncate)`\" >> .ver
++ @echo \#define LINUX_COMPILE_DOMAIN \"unslung.org\" >> .ver
+ @echo \#define LINUX_COMPILER \"`$(CC) $(CFLAGS) -v 2>&1 | tail -n 1`\" >> .ver
+ @mv -f .ver $@
+ @rm -f .ver1