aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/unslung-kernel/short_loadbytes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/unslung-kernel/short_loadbytes.patch')
-rw-r--r--recipes/linux/unslung-kernel/short_loadbytes.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/linux/unslung-kernel/short_loadbytes.patch b/recipes/linux/unslung-kernel/short_loadbytes.patch
new file mode 100644
index 0000000000..f0b514225c
--- /dev/null
+++ b/recipes/linux/unslung-kernel/short_loadbytes.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- linux-2.4.22/arch/arm/Makefile~short_loadbytes 2004-09-08 19:34:45.000000000 -0500
++++ linux-2.4.22/arch/arm/Makefile 2004-09-08 19:34:53.000000000 -0500
+@@ -74,8 +74,8 @@
+ tune-$(CONFIG_CPU_XSCALE) :=-mtune=strongarm
+ endif
+
+-CFLAGS_BOOT :=$(apcs-y) $(arch-y) $(tune-y) -mshort-load-bytes -msoft-float -Uarm
+-CFLAGS +=$(apcs-y) $(arch-y) $(tune-y) -mshort-load-bytes -msoft-float -Uarm
++CFLAGS_BOOT :=$(apcs-y) $(arch-y) $(tune-y) $(call check_gcc,-malignment-traps,-mshort-load-bytes) -msoft-float -Uarm
++CFLAGS +=$(apcs-y) $(arch-y) $(tune-y) $(call check_gcc,-malignment-traps,-mshort-load-bytes) -msoft-float -Uarm
+ AFLAGS +=$(apcs-y) $(arch-y) -msoft-float
+
+ ifeq ($(CONFIG_CPU_26),y)