summaryrefslogtreecommitdiffstats
path: root/recipes/lirc/lirc-modules_0.8.4a.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lirc/lirc-modules_0.8.4a.bb')
-rw-r--r--recipes/lirc/lirc-modules_0.8.4a.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/lirc/lirc-modules_0.8.4a.bb b/recipes/lirc/lirc-modules_0.8.4a.bb
new file mode 100644
index 0000000000..3815372a47
--- /dev/null
+++ b/recipes/lirc/lirc-modules_0.8.4a.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls. This package contains the lirc kernel modules."
+SECTION = "base"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.lirc.org"
+LICENSE = "GPL"
+DEPENDS = "virtual/kernel fakeroot-native setserial"
+PR = "r0"
+
+SRCDATE=${@bb.data.getVar('PV', d, 1)[9:]}
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz"
+S = "${WORKDIR}/lirc-${PV}"
+
+
+inherit autotools module
+
+require lirc-config.inc
+
+MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make V=1' -C drivers"
+
+fakeroot do_install() {
+ oe_runmake -C drivers DESTDIR="${D}" moduledir="/lib/modules/${KERNEL_VERSION}/lirc" install
+ rm -rf ${D}/dev
+}
+
+# this is for distributions that don't use udev
+pkg_postinst_append() {
+if [ ! -c $D/dev/lirc -a ! -f /sbin/udevd ]; then mknod $D/dev/lirc c 61 0; fi
+}
+
+FILES_${PN} = "/lib/modules"