aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/llvm')
-rw-r--r--recipes/llvm/llvm-common.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/llvm/llvm-common.bb b/recipes/llvm/llvm-common.bb
index a2dad52b43..3de8f7f7b2 100644
--- a/recipes/llvm/llvm-common.bb
+++ b/recipes/llvm/llvm-common.bb
@@ -2,6 +2,8 @@ PR = "r1"
DESCRIPTION = "Helper script for OE's llvm support"
+PR = "r1"
+
BBCLASSEXTEND = "native"
SRC_URI = "file://llvm-config"
@@ -14,3 +16,15 @@ do_install() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/llvm-config ${D}${bindir}
}
+
+# For llvm-common the script should end up in STAGING_BINDIR_CROSS
+# and for llvm-common-native it should be in STAGING_BINDIR. The
+# script works together with a script that is installed by a
+# corresponding llvm(-native) package.
+DESTINATION = "${STAGING_BINDIR_CROSS}"
+DESTINATION_virtclass-native = "${STAGING_BINDIR}"
+
+do_stage() {
+ install -d ${DESTINATION}
+ install -m 0755 ${WORKDIR}/llvm-config ${DESTINATION}
+}