aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lzo
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lzo')
-rw-r--r--recipes/lzo/lzo-native_1.08.bb3
-rw-r--r--recipes/lzo/lzo_1.08.bb36
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes/lzo/lzo-native_1.08.bb b/recipes/lzo/lzo-native_1.08.bb
new file mode 100644
index 0000000000..3de88e34bf
--- /dev/null
+++ b/recipes/lzo/lzo-native_1.08.bb
@@ -0,0 +1,3 @@
+require lzo_${PV}.bb
+inherit native
+S = "${WORKDIR}/lzo-${PV}" \ No newline at end of file
diff --git a/recipes/lzo/lzo_1.08.bb b/recipes/lzo/lzo_1.08.bb
new file mode 100644
index 0000000000..a01912da0f
--- /dev/null
+++ b/recipes/lzo/lzo_1.08.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Lossless data compression library"
+HOMEPAGE = "http://www.oberhumer.com/opensource/lzo/"
+LICENSE = "GPLv2"
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r14"
+
+SRC_URI = "http://www.oberhumer.com/opensource/lzo/download/lzo-${PV}.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-shared"
+
+#do_configure () {
+# # override this function to avoid the autoconf/automake/aclocal/autoheader
+# # calls for now
+# gnu-configize
+# oe_runconf
+#}
+
+do_stage() {
+ install -m 0644 include/lzo1.h ${STAGING_INCDIR}/lzo1.h
+ install -m 0644 include/lzo16bit.h ${STAGING_INCDIR}/lzo16bit.h
+ install -m 0644 include/lzo1a.h ${STAGING_INCDIR}/lzo1a.h
+ install -m 0644 include/lzo1b.h ${STAGING_INCDIR}/lzo1b.h
+ install -m 0644 include/lzo1c.h ${STAGING_INCDIR}/lzo1c.h
+ install -m 0644 include/lzo1f.h ${STAGING_INCDIR}/lzo1f.h
+ install -m 0644 include/lzo1x.h ${STAGING_INCDIR}/lzo1x.h
+ install -m 0644 include/lzo1y.h ${STAGING_INCDIR}/lzo1y.h
+ install -m 0644 include/lzo1z.h ${STAGING_INCDIR}/lzo1z.h
+ install -m 0644 include/lzo2a.h ${STAGING_INCDIR}/lzo2a.h
+ install -m 0644 include/lzoconf.h ${STAGING_INCDIR}/lzoconf.h
+ install -m 0644 include/lzoutil.h ${STAGING_INCDIR}/lzoutil.h
+
+ oe_libinstall -a -so -C src liblzo ${STAGING_LIBDIR}
+}