aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/maemo/lessertunjo_0.0.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/maemo/lessertunjo_0.0.10.bb')
-rw-r--r--recipes/maemo/lessertunjo_0.0.10.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/maemo/lessertunjo_0.0.10.bb b/recipes/maemo/lessertunjo_0.0.10.bb
new file mode 100644
index 0000000000..e084d1e050
--- /dev/null
+++ b/recipes/maemo/lessertunjo_0.0.10.bb
@@ -0,0 +1,22 @@
+LICENSE = "LGPL"
+
+DEPENDS = "gconf-osso hildon-libs dbus libosso"
+SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/l/lessertunjo/lessertunjo_${PV}-3.tar.gz"
+
+inherit pkgconfig
+
+S = "${WORKDIR}/lessertunjo"
+LDFLAGS += " -losso -L${STAGING_LIBDIR} -I${STAGING_INCDIR} -I${STAGING_LIBDIR}/dbus-1.0/include -I${STAGING_INCDIR}/dbus-1.0 -I${STAGING_INCDIR}/glib-2.0 -I${STAGING_INCDIR}/gconf/2"
+
+
+do_install() {
+ install -d ${D}${libdir}
+ install -m 755 *so.0.0.10 ${D}${libdir}
+}
+
+do_stage() {
+ oe_libinstall -so libshadowapp libshadowappd ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}
+ install -m 644 *.h ${STAGING_INCDIR}
+
+}