aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/maemo4/libosso-help_2.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/maemo4/libosso-help_2.1.2.bb')
-rw-r--r--recipes/maemo4/libosso-help_2.1.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/maemo4/libosso-help_2.1.2.bb b/recipes/maemo4/libosso-help_2.1.2.bb
new file mode 100644
index 0000000000..8a35e1a4f0
--- /dev/null
+++ b/recipes/maemo4/libosso-help_2.1.2.bb
@@ -0,0 +1,24 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia osso help library"
+
+DEPENDS = "libhildonhelp libosso gtkhtml-3.8 libxml2 "
+
+PR = "r0"
+
+SRC_URI = "http://repository.maemo.org/pool/sardine-experimental/main.disabled/source/libo/libosso-help/libosso-help_${PV}-2.tar.gz"
+
+inherit autotools pkgconfig lib_package
+
+S = "${WORKDIR}/2.1.2-2"
+
+do_configure_prepend() {
+ # remove Werror from OSSO_CFLAGS
+ sed -i s:-Werror::g configure.ac
+ sed -i -e s:AC_CONFIG_SRCDIR:#AC_CONFIG_SRCDIR:g configure.ac
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+