aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/maemo4/osso-ic-oss_1.0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/maemo4/osso-ic-oss_1.0.4.bb')
-rw-r--r--recipes/maemo4/osso-ic-oss_1.0.4.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/maemo4/osso-ic-oss_1.0.4.bb b/recipes/maemo4/osso-ic-oss_1.0.4.bb
new file mode 100644
index 0000000000..04ec84e4e2
--- /dev/null
+++ b/recipes/maemo4/osso-ic-oss_1.0.4.bb
@@ -0,0 +1,25 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Nokia osso-ic library"
+
+DEPENDS = "dbus-glib glib-2.0 libosso"
+
+PR = "r1"
+
+# No sources for that Maemo revision any more.
+SRC_URI = "http://repository.maemo.org/pool/bora/free/source/${PN}_${PV}.tar.gz \
+ file://dbus-api-update.patch;patch=1 "
+
+inherit autotools pkgconfig lib_package
+
+do_configure_prepend() {
+ # remove Werror from OSSO_CFLAGS
+ sed -i s:-Werror::g configure.ac
+}
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ autotools_stage_all
+}
+
+