aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mamona/mamonaim-e-applet_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mamona/mamonaim-e-applet_git.bb')
-rw-r--r--recipes/mamona/mamonaim-e-applet_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/mamona/mamonaim-e-applet_git.bb b/recipes/mamona/mamonaim-e-applet_git.bb
new file mode 100644
index 0000000000..6f45a457c4
--- /dev/null
+++ b/recipes/mamona/mamonaim-e-applet_git.bb
@@ -0,0 +1,36 @@
+# Copyright (C) 2008 Instituto Nokia de Tecnologia
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Mamona-IM Enlightenment Applet"
+HOMEPAGE = "http://dev.openbossa.org/trac/mamona/wiki"
+LICENSE = "MIT BSD"
+DEPENDS = "mamona-input-methods e-wm"
+PR = "r0"
+
+PV = "0.1+git"
+
+inherit autotools pkgconfig
+
+SRC_URI = "git://dev.openbossa.org/mamona/projects/mamonaim_e_applet.git;protocol=http"
+
+S = "${WORKDIR}/git"
+
+# E Applet
+FILES_${PN} = "\
+ ${libdir}/enlightenment/modules/mamonaim/module.desktop \
+ ${libdir}/enlightenment/modules/mamonaim/mamonaim.edj \
+ ${libdir}/enlightenment/modules/mamonaim/e-module-mamonaim.edj \
+ ${libdir}/enlightenment/modules/mamonaim/*.png \
+ ${libdir}/enlightenment/modules/mamonaim/*/module.so \
+ "
+FILES_${PN}-dev = "\
+ ${libdir}/enlightenment/modules/mamonaim/*/module.la \
+ ${libdir}/enlightenment/modules/mamonaim/*/module.a \
+ "
+FILES_${PN}-dbg = "\
+ ${libdir}/enlightenment/modules/mamonaim/*/.debug \
+ "
+
+do_configure_prepend() {
+ ./autogen.sh
+}