aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mamona
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mamona')
-rw-r--r--recipes/mamona/bash-noemu_3.2.bb4
-rw-r--r--recipes/mamona/binutils-noemu_2.17.50.0.5.bb14
-rw-r--r--recipes/mamona/binutils-noemu_2.18.bb16
-rw-r--r--recipes/mamona/cx3110x-770he_0.8.1.bb16
-rw-r--r--recipes/mamona/cx3110x-chinooke_2.0.15.bb6
-rw-r--r--recipes/mamona/cx3110x-diablo_2.0.15.bb6
-rw-r--r--recipes/mamona/gcc-noemu_4.1.1.bb54
-rw-r--r--recipes/mamona/gcc-noemu_4.1.2.bb74
8 files changed, 95 insertions, 95 deletions
diff --git a/recipes/mamona/bash-noemu_3.2.bb b/recipes/mamona/bash-noemu_3.2.bb
index 7e846742d7..88bafb01e8 100644
--- a/recipes/mamona/bash-noemu_3.2.bb
+++ b/recipes/mamona/bash-noemu_3.2.bb
@@ -5,8 +5,8 @@ RCONFLICTS = "bash"
RREPLACES = "bash"
SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
- file://001-005.patch;patch=1 \
- file://006-add_internal_libcpwd_functions.patch;patch=1"
+ file://001-005.patch;apply=yes \
+ file://006-add_internal_libcpwd_functions.patch;apply=yes"
S = "${WORKDIR}/bash-${PV}"
diff --git a/recipes/mamona/binutils-noemu_2.17.50.0.5.bb b/recipes/mamona/binutils-noemu_2.17.50.0.5.bb
index d4a1ef6f97..24966b327b 100644
--- a/recipes/mamona/binutils-noemu_2.17.50.0.5.bb
+++ b/recipes/mamona/binutils-noemu_2.17.50.0.5.bb
@@ -7,13 +7,13 @@ RREPLACES = "binutils"
SRC_URI = \
"${KERNELORG_MIRROR}/pub/linux/devel/binutils/binutils-${PV}.tar.bz2 \
- file://binutils-2.16.91.0.6-objcopy-rename-errorcode.patch;patch=1 \
- file://binutils-uclibc-100-uclibc-conf.patch;patch=1 \
- file://binutils-configure-texinfo-version.patch;patch=1 \
- file://110-arm-eabi-conf.patch;patch=1 \
- file://binutils-uclibc-300-001_ld_makefile_patch.patch;patch=1 \
- file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \
- file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
+ file://binutils-2.16.91.0.6-objcopy-rename-errorcode.patch;apply=yes \
+ file://binutils-uclibc-100-uclibc-conf.patch;apply=yes \
+ file://binutils-configure-texinfo-version.patch;apply=yes \
+ file://110-arm-eabi-conf.patch;apply=yes \
+ file://binutils-uclibc-300-001_ld_makefile_patch.patch;apply=yes \
+ file://binutils-uclibc-300-006_better_file_error.patch;apply=yes \
+ file://binutils-uclibc-300-012_check_ldrunpath_length.patch;apply=yes \
"
EXTRA_OECONF = "--with-sysroot=${CROSS_DIR}/${TARGET_SYS} \
diff --git a/recipes/mamona/binutils-noemu_2.18.bb b/recipes/mamona/binutils-noemu_2.18.bb
index 1cee45211b..e84d0eab6f 100644
--- a/recipes/mamona/binutils-noemu_2.18.bb
+++ b/recipes/mamona/binutils-noemu_2.18.bb
@@ -9,17 +9,17 @@ RREPLACES_binutils-noemu-symlinks = "binutils-symlinks"
SRC_URI = "\
${GNU_MIRROR}/binutils/binutils-${PV}.tar.bz2 \
- file://binutils-2.16.91.0.6-objcopy-rename-errorcode.patch;patch=1 \
- file://binutils-configure-texinfo-version.patch;patch=1 \
- file://binutils-uclibc-100-uclibc-conf.patch;patch=1 \
- file://110-arm-eabi-conf.patch;patch=1 \
- file://binutils-uclibc-300-001_ld_makefile_patch.patch;patch=1 \
- file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \
- file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
+ file://binutils-2.16.91.0.6-objcopy-rename-errorcode.patch;apply=yes \
+ file://binutils-configure-texinfo-version.patch;apply=yes \
+ file://binutils-uclibc-100-uclibc-conf.patch;apply=yes \
+ file://110-arm-eabi-conf.patch;apply=yes \
+ file://binutils-uclibc-300-001_ld_makefile_patch.patch;apply=yes \
+ file://binutils-uclibc-300-006_better_file_error.patch;apply=yes \
+ file://binutils-uclibc-300-012_check_ldrunpath_length.patch;apply=yes \
"
# powerpc patches
-SRC_URI += "file://binutils-2.16.1-e300c2c3.patch;patch=1"
+SRC_URI += "file://binutils-2.16.1-e300c2c3.patch;apply=yes"
EXTRA_OECONF = "--program-prefix=${TARGET_PREFIX} --disable-shared"
diff --git a/recipes/mamona/cx3110x-770he_0.8.1.bb b/recipes/mamona/cx3110x-770he_0.8.1.bb
index 781a0546e0..22609a6373 100644
--- a/recipes/mamona/cx3110x-770he_0.8.1.bb
+++ b/recipes/mamona/cx3110x-770he_0.8.1.bb
@@ -14,14 +14,14 @@ SRC_URI += "https://garage.maemo.org/frs/download.php/2443/cx3110x-0.8.1.tar.gz;
http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2005q3-2-arm-none-eabi-i686-pc-linux-gnu.tar.bz2;name=arm \
http://dev.openbossa.org/mamona/sources/kernel-source-${KERVER}.tar.gz;name=kernel \
file://defconfig \
- file://fix_mem_corruption.patch;patch=1 \
- file://fix_mem_allign.patch;patch=1 \
- file://cx3110x.patch;patch=1 \
- file://fix_cross_makefile.patch;patch=1 \
- file://fix_ssid_data_length.patch;patch=1 \
- file://770_performance_improvements.patch;patch=1 \
- file://create_sysfs_link_for_wlan0.patch;patch=1 \
- file://fix_opps_while_connecting_with_nm.patch;patch=1 \
+ file://fix_mem_corruption.patch;apply=yes \
+ file://fix_mem_allign.patch;apply=yes \
+ file://cx3110x.patch;apply=yes \
+ file://fix_cross_makefile.patch;apply=yes \
+ file://fix_ssid_data_length.patch;apply=yes \
+ file://770_performance_improvements.patch;apply=yes \
+ file://create_sysfs_link_for_wlan0.patch;apply=yes \
+ file://fix_opps_while_connecting_with_nm.patch;apply=yes \
"
SRC_URI[archive.md5sum] = "85c115a81fa4429bee2cd16bfe961d44"
diff --git a/recipes/mamona/cx3110x-chinooke_2.0.15.bb b/recipes/mamona/cx3110x-chinooke_2.0.15.bb
index 24536a9671..2a4018edb2 100644
--- a/recipes/mamona/cx3110x-chinooke_2.0.15.bb
+++ b/recipes/mamona/cx3110x-chinooke_2.0.15.bb
@@ -15,9 +15,9 @@ SRC_URI += "\
http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2005q3-2-arm-none-eabi-i686-pc-linux-gnu.tar.bz2;name=arm \
http://repository.maemo.org/pool/chinook/free/k/kernel-source-rx-34/kernel-source-rx-34_2.6.21.0.orig.tar.gz;name=kernel \
http://repository.maemo.org/pool/chinook/free/k/kernel-source-rx-34/kernel-source-rx-34_2.6.21.0-osso71.diff.gz;name=kernelpatch \
- file://cx3110x.patch;patch=1 \
- file://create_sysfs_link_for_wlan0.patch;patch=1 \
- file://fix_old_include.patch;patch=1 \
+ file://cx3110x.patch;apply=yes \
+ file://create_sysfs_link_for_wlan0.patch;apply=yes \
+ file://fix_old_include.patch;apply=yes \
"
SRC_URI[archive.md5sum] = "6ac5db5e602ef205200428a6612b4036"
diff --git a/recipes/mamona/cx3110x-diablo_2.0.15.bb b/recipes/mamona/cx3110x-diablo_2.0.15.bb
index 73e684c54c..eb3d78f8f2 100644
--- a/recipes/mamona/cx3110x-diablo_2.0.15.bb
+++ b/recipes/mamona/cx3110x-diablo_2.0.15.bb
@@ -14,9 +14,9 @@ SRC_URI += "\
http://repository.maemo.org/pool/maemo4.1/free/c/cx3110x-module-src/cx3110x-module-src_2.0.15-1.tar.gz;name=archive \
http://www.codesourcery.com/public/gnu_toolchain/arm-none-eabi/arm-2005q3-2-arm-none-eabi-i686-pc-linux-gnu.tar.bz2;name=arm \
http://repository.maemo.org/pool/maemo4.1/free/k/kernel-source-diablo/kernel-source-diablo_2.6.21-200823maemo6.tar.gz;name=kernel \
- file://cx3110x.patch;patch=1 \
- file://create_sysfs_link_for_wlan0.patch;patch=1 \
- file://fix_old_include.patch;patch=1 \
+ file://cx3110x.patch;apply=yes \
+ file://create_sysfs_link_for_wlan0.patch;apply=yes \
+ file://fix_old_include.patch;apply=yes \
"
SRC_URI[archive.md5sum] = "6ac5db5e602ef205200428a6612b4036"
diff --git a/recipes/mamona/gcc-noemu_4.1.1.bb b/recipes/mamona/gcc-noemu_4.1.1.bb
index 32e021bb98..9410f28f97 100644
--- a/recipes/mamona/gcc-noemu_4.1.1.bb
+++ b/recipes/mamona/gcc-noemu_4.1.1.bb
@@ -12,38 +12,38 @@ inherit autotools gettext
require gcc-package-noemu.inc
SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
- file://100-uclibc-conf.patch;patch=1 \
- file://110-arm-eabi.patch;patch=1 \
- file://200-uclibc-locale.patch;patch=1 \
- file://300-libstdc++-pic.patch;patch=1 \
- file://301-missing-execinfo_h.patch;patch=1 \
- file://302-c99-snprintf.patch;patch=1 \
- file://303-c99-complex-ugly-hack.patch;patch=1 \
- file://304-index_macro.patch;patch=1 \
- file://602-sdk-libstdc++-includes.patch;patch=1 \
- file://740-sh-pr24836.patch;patch=1 \
- file://800-arm-bigendian.patch;patch=1 \
- file://801-arm-bigendian-eabi.patch;patch=1 \
- file://arm-nolibfloat.patch;patch=1 \
- file://arm-softfloat.patch;patch=1 \
- file://gcc41-configure.in.patch;patch=1 \
- file://arm-thumb.patch;patch=1 \
- file://arm-thumb-cache.patch;patch=1 \
- file://ldflags.patch;patch=1 \
- file://cse.patch;patch=1 \
- file://zecke-xgcc-cpp.patch;patch=1 \
- file://unbreak-armv4t.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
- file://gcc-4.1.1-pr13685-1.patch;patch=1 \
- file://gcc-ignore-cache.patch;patch=1 \
+ file://100-uclibc-conf.patch;apply=yes \
+ file://110-arm-eabi.patch;apply=yes \
+ file://200-uclibc-locale.patch;apply=yes \
+ file://300-libstdc++-pic.patch;apply=yes \
+ file://301-missing-execinfo_h.patch;apply=yes \
+ file://302-c99-snprintf.patch;apply=yes \
+ file://303-c99-complex-ugly-hack.patch;apply=yes \
+ file://304-index_macro.patch;apply=yes \
+ file://602-sdk-libstdc++-includes.patch;apply=yes \
+ file://740-sh-pr24836.patch;apply=yes \
+ file://800-arm-bigendian.patch;apply=yes \
+ file://801-arm-bigendian-eabi.patch;apply=yes \
+ file://arm-nolibfloat.patch;apply=yes \
+ file://arm-softfloat.patch;apply=yes \
+ file://gcc41-configure.in.patch;apply=yes \
+ file://arm-thumb.patch;apply=yes \
+ file://arm-thumb-cache.patch;apply=yes \
+ file://ldflags.patch;apply=yes \
+ file://cse.patch;apply=yes \
+ file://zecke-xgcc-cpp.patch;apply=yes \
+ file://unbreak-armv4t.patch;apply=yes \
+ file://fix-ICE-in-arm_unwind_emit_set.diff;apply=yes \
+ file://gcc-4.1.1-pr13685-1.patch;apply=yes \
+ file://gcc-ignore-cache.patch;apply=yes \
"
-SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
+SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;apply=yes "
#This is a dirty hack to get gcc 4.1.1 to compile for glibc AND uclibc on ppc
#the patch that is need it to get gcc support soft-floats with glibc, makes gcc fail with uclibc
-SRC_URI_append_linux = " file://ppc-gcc-41-20060515.patch;patch=1 \
- file://ppc-sfp-long-double-gcc411-7.patch;patch=1 "
+SRC_URI_append_linux = " file://ppc-gcc-41-20060515.patch;apply=yes \
+ file://ppc-sfp-long-double-gcc411-7.patch;apply=yes "
#Set the fortran bits
diff --git a/recipes/mamona/gcc-noemu_4.1.2.bb b/recipes/mamona/gcc-noemu_4.1.2.bb
index caffd68573..86be907087 100644
--- a/recipes/mamona/gcc-noemu_4.1.2.bb
+++ b/recipes/mamona/gcc-noemu_4.1.2.bb
@@ -18,47 +18,47 @@ inherit autotools gettext
require gcc-package-noemu.inc
SRC_URI = "ftp://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.2/gcc-4.1.2.tar.bz2 \
- file://100-uclibc-conf.patch;patch=1 \
- file://110-arm-eabi.patch;patch=1 \
- file://200-uclibc-locale.patch;patch=1 \
- file://300-libstdc++-pic.patch;patch=1 \
- file://301-missing-execinfo_h.patch;patch=1 \
- file://302-c99-snprintf.patch;patch=1 \
- file://303-c99-complex-ugly-hack.patch;patch=1 \
- file://304-index_macro.patch;patch=1 \
- file://602-sdk-libstdc++-includes.patch;patch=1 \
- file://740-sh-pr24836.patch;patch=1 \
- file://800-arm-bigendian.patch;patch=1 \
- file://arm-nolibfloat.patch;patch=1 \
- file://arm-softfloat.patch;patch=1 \
- file://gcc41-configure.in.patch;patch=1 \
- file://arm-thumb.patch;patch=1 \
- file://arm-thumb-cache.patch;patch=1 \
- file://ldflags.patch;patch=1 \
- file://zecke-xgcc-cpp.patch;patch=1 \
- file://unbreak-armv4t.patch;patch=1 \
- file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
- file://cache-amnesia.patch;patch=1 \
- file://gfortran.patch;patch=1 \
- file://gcc-4.0.2-e300c2c3.patch;patch=1 \
- file://pr34130.patch;patch=1 \
+ file://100-uclibc-conf.patch;apply=yes \
+ file://110-arm-eabi.patch;apply=yes \
+ file://200-uclibc-locale.patch;apply=yes \
+ file://300-libstdc++-pic.patch;apply=yes \
+ file://301-missing-execinfo_h.patch;apply=yes \
+ file://302-c99-snprintf.patch;apply=yes \
+ file://303-c99-complex-ugly-hack.patch;apply=yes \
+ file://304-index_macro.patch;apply=yes \
+ file://602-sdk-libstdc++-includes.patch;apply=yes \
+ file://740-sh-pr24836.patch;apply=yes \
+ file://800-arm-bigendian.patch;apply=yes \
+ file://arm-nolibfloat.patch;apply=yes \
+ file://arm-softfloat.patch;apply=yes \
+ file://gcc41-configure.in.patch;apply=yes \
+ file://arm-thumb.patch;apply=yes \
+ file://arm-thumb-cache.patch;apply=yes \
+ file://ldflags.patch;apply=yes \
+ file://zecke-xgcc-cpp.patch;apply=yes \
+ file://unbreak-armv4t.patch;apply=yes \
+ file://fix-ICE-in-arm_unwind_emit_set.diff;apply=yes \
+ file://cache-amnesia.patch;apply=yes \
+ file://gfortran.patch;apply=yes \
+ file://gcc-4.0.2-e300c2c3.patch;apply=yes \
+ file://pr34130.patch;apply=yes \
"
-SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;patch=1 "
+SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch;apply=yes "
SRC_URI_avr32 = "http://www.angstrom-distribution.org/unstable/sources/gcc-4.1.2-atmel.1.1.0.tar.gz \
-# file://100-uclibc-conf.patch;patch=1 \
-# file://200-uclibc-locale.patch;patch=1 \
-# file://300-libstdc++-pic.patch;patch=1 \
- file://301-missing-execinfo_h.patch;patch=1 \
- file://302-c99-snprintf.patch;patch=1 \
- file://303-c99-complex-ugly-hack.patch;patch=1 \
- file://304-index_macro.patch;patch=1 \
- file://602-sdk-libstdc++-includes.patch;patch=1 \
- file://gcc41-configure.in.patch;patch=1 \
- file://ldflags.patch;patch=1 \
- file://zecke-xgcc-cpp.patch;patch=1 \
- file://cache-amnesia.patch;patch=1 \
+# file://100-uclibc-conf.patch;apply=yes \
+# file://200-uclibc-locale.patch;apply=yes \
+# file://300-libstdc++-pic.patch;apply=yes \
+ file://301-missing-execinfo_h.patch;apply=yes \
+ file://302-c99-snprintf.patch;apply=yes \
+ file://303-c99-complex-ugly-hack.patch;apply=yes \
+ file://304-index_macro.patch;apply=yes \
+ file://602-sdk-libstdc++-includes.patch;apply=yes \
+ file://gcc41-configure.in.patch;apply=yes \
+ file://ldflags.patch;apply=yes \
+ file://zecke-xgcc-cpp.patch;apply=yes \
+ file://cache-amnesia.patch;apply=yes \
"
do_compile_prepend_avr32() {