aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/matchbox-wm/matchbox-wm_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/matchbox-wm/matchbox-wm_svn.bb')
-rw-r--r--recipes/matchbox-wm/matchbox-wm_svn.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/matchbox-wm/matchbox-wm_svn.bb b/recipes/matchbox-wm/matchbox-wm_svn.bb
new file mode 100644
index 0000000000..554811d597
--- /dev/null
+++ b/recipes/matchbox-wm/matchbox-wm_svn.bb
@@ -0,0 +1,33 @@
+require matchbox-wm.inc
+
+DEPENDS = "libmatchbox virtual/libx11 libxext libxcomposite libxfixes libxdamage libxrender startup-notification expat gconf "
+RDEPENDS = ""
+PV = "1.1+svn${SRCDATE}"
+PR = "r4"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-window-manager;proto=http \
+ file://kbdconfig"
+
+S = "${WORKDIR}/matchbox-window-manager"
+
+inherit autotools pkgconfig update-alternatives
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_PRIORITY = "10"
+
+FILES_${PN} = "${bindir}/* \
+ ${datadir}/matchbox \
+ ${sysconfdir}/matchbox \
+ ${datadir}/themes/blondie/matchbox \
+ ${datadir}/themes/Default/matchbox \
+ ${datadir}/themes/MBOpus/matchbox"
+
+EXTRA_OECONF = "--enable-composite --enable-startup-notification --disable-xrm"
+
+do_install_prepend() {
+ install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
+}
+