summaryrefslogtreecommitdiffstats
path: root/recipes/matchbox2/matchbox-panel-2_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/matchbox2/matchbox-panel-2_svn.bb')
-rw-r--r--recipes/matchbox2/matchbox-panel-2_svn.bb40
1 files changed, 22 insertions, 18 deletions
diff --git a/recipes/matchbox2/matchbox-panel-2_svn.bb b/recipes/matchbox2/matchbox-panel-2_svn.bb
index 79fafff202..667b54967f 100644
--- a/recipes/matchbox2/matchbox-panel-2_svn.bb
+++ b/recipes/matchbox2/matchbox-panel-2_svn.bb
@@ -1,27 +1,31 @@
DESCRIPTION = "matchbox-panel-2 is a lightweight dock (system tray) application based on Gtk+"
-LICENSE = "GPL"
+LICENSE = "GPLv2"
SECTION = "x11/panels"
-DEPENDS = "gtk+ apmd startup-notification"
-PV = "0.1+svnr${SRCREV}"
-PR = "r8"
+DEPENDS = "gtk+ startup-notification dbus dbus-glib matchbox-panel-2-icon-themes"
+DEPENDS += " ${@base_contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
+DEPENDS += " ${@base_contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
+RDEPENDS_${PN} = "matchbox-panel-2-icon-theme"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PV = "2.0+svnr${SRCREV}"
+PR = "r0"
-SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
-S = "${WORKDIR}/${PN}"
+inherit autotools_stage pkgconfig
-inherit autotools pkgconfig
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
+ file://scaling-image-double-free.patch;patch=1;pnum=0 \
+ file://startup-invalid-access.patch;patch=1;pnum=0 \
+ file://startup-shown-uninitialized.patch;patch=1;pnum=0 \
+ file://themeable-icons.patch;patch=1;pnum=0 \
+"
+S = "${WORKDIR}/${PN}"
-EXTRA_OECONF = "--enable-startup-notification --disable-libnotify"
+EXTRA_OECONF = "--disable-static --program-transform-name='s/$/-2/'"
+EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"
+EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "apm", "--with-battery=apm", "",d)}"
-# matchbox-<anything>-2 aims to replace their -1 counterpart, but at this point in time it's unfinished and unusable, so make it parallel installable
do_install_append() {
- mv ${D}${bindir}/matchbox-panel ${D}${bindir}/matchbox-panel-2
+ rm ${D}${libdir}/matchbox-panel/lib*.*a
}
-do_stage() {
- autotools_stage_all
-}
-
-PACKAGES += "${PN}-applets"
-FILES_${PN}-applets = "${libdir}/matchbox-panel/lib*.so* ${datadir}/*"
-FILES_${PN}-dev += "${libdir}/matchbox-panel/lib*.a ${libdir}/matchbox-panel/lib*.la"
-
+FILES_${PN} += "${libdir}/matchbox-panel/*.so"
+FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"