aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mbmerlin
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mbmerlin')
-rw-r--r--recipes/mbmerlin/mbmerlin-0.8.1-2/fix_makefile.patch11
-rw-r--r--recipes/mbmerlin/mbmerlin_0.8.1-2.bb18
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes/mbmerlin/mbmerlin-0.8.1-2/fix_makefile.patch b/recipes/mbmerlin/mbmerlin-0.8.1-2/fix_makefile.patch
new file mode 100644
index 0000000000..0f2dabd8a3
--- /dev/null
+++ b/recipes/mbmerlin/mbmerlin-0.8.1-2/fix_makefile.patch
@@ -0,0 +1,11 @@
+diff -urNd ../mbmerlin-0.8.1-2-r3/mbmerlin/Makefile mbmerlin/Makefile
+--- ../mbmerlin-0.8.1-2-r3/mbmerlin/Makefile 2004-07-29 21:17:13.000000000 +0100
++++ mbmerlin/Makefile 2004-08-01 11:32:09.000000000 +0100
+@@ -106,6 +106,7 @@
+ install mbmerlin.desktop $(DESTDIR)/usr/share/applications/inputmethods
+ install -d $(DESTDIR)/usr/share/pixmaps
+ install mbmerlin.png $(DESTDIR)/usr/share/pixmaps
++ install -d $(DESTDIR)/$(INSTALL_DIR)
+ install mbmerlin $(DESTDIR)/$(INSTALL_DIR)
+
+ ipkg:
diff --git a/recipes/mbmerlin/mbmerlin_0.8.1-2.bb b/recipes/mbmerlin/mbmerlin_0.8.1-2.bb
new file mode 100644
index 0000000000..4842aac7ff
--- /dev/null
+++ b/recipes/mbmerlin/mbmerlin_0.8.1-2.bb
@@ -0,0 +1,18 @@
+LICENSE = "GPL"
+PR = "r3"
+
+inherit pkgconfig gpe
+
+DEPENDS = "virtual/xserver libxft startup-notification"
+
+SECTION = "x11"
+PRIORITY = "optional"
+FILES_${PN} = "${sysconfdir} ${bindir} ${datadir}/mbmerlin ${datadir}/applications"
+FILES_${PN} += " ${datadir}/pixmaps"
+
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.gz \
+ file://fix_makefile.patch;patch=1"
+
+S = "${WORKDIR}/mbmerlin"
+
+CFLAGS += " -D_GNU_SOURCE"