aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mesa/freeglut_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mesa/freeglut_2.4.0.bb')
-rw-r--r--recipes/mesa/freeglut_2.4.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/mesa/freeglut_2.4.0.bb b/recipes/mesa/freeglut_2.4.0.bb
new file mode 100644
index 0000000000..a244fb23e1
--- /dev/null
+++ b/recipes/mesa/freeglut_2.4.0.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "freeglut is a completely OpenSourced alternative to the OpenGL Utility Toolkit (GLUT) library. "
+LICENSE = "MIT/X11"
+
+DEPENDS = "mesa"
+
+SRC_URI = "http://dfn.dl.sourceforge.net/sourceforge/freeglut/freeglut-${PV}.tar.gz"
+
+inherit autotools lib_package
+
+export CCLD="${CXX}"
+
+do_configure_prepend() {
+ sed -i -e s:-Werror::g -e s:AC_PROG_CC:AC_PROG_CXX:g configure.ac
+}
+
+do_configure_append() {
+ for i in $(find . -name "Makefile") ; do
+ sed -i -e /^CCLD/d $i
+ done
+}
+
+
+do_stage() {
+ autotools_stage_all
+}
+