aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mesa/mesa_6.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mesa/mesa_6.0.1.bb')
-rw-r--r--recipes/mesa/mesa_6.0.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/mesa/mesa_6.0.1.bb b/recipes/mesa/mesa_6.0.1.bb
new file mode 100644
index 0000000000..d8c857fef7
--- /dev/null
+++ b/recipes/mesa/mesa_6.0.1.bb
@@ -0,0 +1,25 @@
+SECTION = "unknown"
+SRC_URI = "${SOURCEFORGE_MIRROR}/mesa3d/MesaLib-${PV}.tar.bz2 \
+ file://Make-config.patch;patch=1 \
+ file://mklib.patch;patch=1"
+S = "${WORKDIR}/Mesa-${PV}"
+LICENSE = "LGPL"
+# gcc-3.4 blows up in gtktext with -frename-registers on arm-linux
+CXXFLAGS := "${@'${CXXFLAGS}'.replace('-frename-registers', '')}"
+DEPENDS = "makedepend-native"
+
+do_compile() {
+ oe_runmake linux CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LD="${LD}" LDFLAGS="${LDFLAGS}"
+}
+
+do_install() {
+ install -d ${D}${libdir}
+ cp -pP lib/* ${D}${libdir}/
+ install -d ${D}${includedir}
+ cp -R include/GL ${D}${includedir}/
+}
+
+do_stage() {
+ cp -pP lib/* ${STAGING_LIBDIR}/
+ cp -R include/GL ${STAGING_INCDIR}/
+}