aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/micro-emacs/micro-emacs_20060909.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/micro-emacs/micro-emacs_20060909.bb')
-rw-r--r--recipes/micro-emacs/micro-emacs_20060909.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/micro-emacs/micro-emacs_20060909.bb b/recipes/micro-emacs/micro-emacs_20060909.bb
new file mode 100644
index 0000000000..f980b368b1
--- /dev/null
+++ b/recipes/micro-emacs/micro-emacs_20060909.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Mini-version of emacs, from http://www.jasspa.com"
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "ncurses"
+
+S = "${WORKDIR}/me060909"
+
+SRC_URI = "http://www.jasspa.com/release_${PV}/jasspa-mesrc-${PV}-2.tar.gz \
+ http://www.jasspa.com/release_${PV}/jasspa-memacros-${PV}.tar.gz \
+ file://${FILESDIR}/zaurus_make.patch;patch=1"
+
+do_compile () {
+ oe_runmake -C src -f zaurus.gmk mec
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/jasspa/macros
+ install -m 0755 src/mec ${D}${bindir}/mec
+ install -m 0644 ${WORKDIR}/*.* ${D}${datadir}/jasspa/macros/
+}
+
+PACKAGES += " ${PN}-macros"
+FILES_${PN}-macros = "${datadir}/jasspa"
+