aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/moblin
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/moblin')
-rw-r--r--recipes/moblin/bognor-regis_git.bb15
-rw-r--r--recipes/moblin/hornsey_git.bb14
-rw-r--r--recipes/moblin/nbtk_git.bb18
3 files changed, 47 insertions, 0 deletions
diff --git a/recipes/moblin/bognor-regis_git.bb b/recipes/moblin/bognor-regis_git.bb
new file mode 100644
index 0000000000..803f7a91da
--- /dev/null
+++ b/recipes/moblin/bognor-regis_git.bb
@@ -0,0 +1,15 @@
+LICENSE = "GPLv2"
+
+SRCREV = "181a62fa73527905fa01859b49eeb9d326ef7742"
+PV = "0.3.1"
+PR_append = "+git${SRCREV}"
+
+DEPENDS = "dbus-glib gstreamer glib-2.0"
+
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
+S = "${WORKDIR}/git"
+
+inherit autotools_stage
+
+FILES_${PN} =+ "${datadir}/dbus-1/services/"
+
diff --git a/recipes/moblin/hornsey_git.bb b/recipes/moblin/hornsey_git.bb
new file mode 100644
index 0000000000..1ea1df502c
--- /dev/null
+++ b/recipes/moblin/hornsey_git.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "The Moblin mediaplayer"
+LICENSE = "LGPLv2.1"
+
+SRCREV = "92e1ebf8f5fdb8f4abcc190213c20b653aac411a"
+PV = "0.0"
+PR_append = "+git${SRCREV}"
+
+DEPENDS = "clutter clutter-gst-0.9 bickley nbtk bognor-regis libunique startup-notification gtk+"
+
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
+S = "${WORKDIR}/git"
+
+inherit autotools_stage
+
diff --git a/recipes/moblin/nbtk_git.bb b/recipes/moblin/nbtk_git.bb
new file mode 100644
index 0000000000..3067a95c57
--- /dev/null
+++ b/recipes/moblin/nbtk_git.bb
@@ -0,0 +1,18 @@
+LICENSE = "LGPLv2.1"
+
+SRCREV = "6a498c374d176be0ed3ef2cd9b2381f452af1de8"
+PV = "0.8.0"
+PR_append = "+git${SRCREV}"
+
+DEPENDS = "glib-2.0 gtk+ libccss clutter-0.9"
+
+SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git"
+S = "${WORKDIR}/git"
+
+inherit autotools_stage
+
+do_configure_prepend () {
+ echo "EXTRA_DIST=" > ${S}/gtk-doc.make
+ echo "CLEANFILES=" >> ${S}/gtk-doc.make
+}
+