aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mozilla
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mozilla')
-rw-r--r--recipes/mozilla/firefox_3.5.4.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes/mozilla/firefox_3.5.4.bb b/recipes/mozilla/firefox_3.5.4.bb
index ea524d181e..48e2709855 100644
--- a/recipes/mozilla/firefox_3.5.4.bb
+++ b/recipes/mozilla/firefox_3.5.4.bb
@@ -1,5 +1,7 @@
DEPENDS += "cairo"
+PR = "r1"
+
SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}.source.tar.bz2 \
file://jsautocfg.h \
file://security-cross.patch;patch=1 \
@@ -61,6 +63,10 @@ do_stage() {
install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${PV}/
done
+ for pc in ${WORKDIR}/*.pc ; do
+ sed -i s:3.5.2:${PV}:g $pc
+ done
+
install -d ${PKG_CONFIG_DIR}
install -m 0644 ${WORKDIR}/firefox-plugin.pc ${PKG_CONFIG_DIR}
install -m 0644 ${WORKDIR}/firefox-xpcom.pc ${PKG_CONFIG_DIR}