aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mpfr
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mpfr')
-rw-r--r--recipes/mpfr/long-long-thumb.patch11
-rw-r--r--recipes/mpfr/mpfr-canadian_2.3.1.bb3
-rw-r--r--recipes/mpfr/mpfr-native_2.1.1.bb4
-rw-r--r--recipes/mpfr/mpfr-native_2.3.1.bb4
-rw-r--r--recipes/mpfr/mpfr-native_2.3.2.bb3
-rw-r--r--recipes/mpfr/mpfr-native_svn.bb3
-rw-r--r--recipes/mpfr/mpfr.inc6
-rw-r--r--recipes/mpfr/mpfr_2.1.1.bb11
-rw-r--r--recipes/mpfr/mpfr_2.3.1.bb12
-rw-r--r--recipes/mpfr/mpfr_2.3.2.bb12
-rw-r--r--recipes/mpfr/mpfr_svn.bb12
11 files changed, 81 insertions, 0 deletions
diff --git a/recipes/mpfr/long-long-thumb.patch b/recipes/mpfr/long-long-thumb.patch
new file mode 100644
index 0000000000..a4029d7990
--- /dev/null
+++ b/recipes/mpfr/long-long-thumb.patch
@@ -0,0 +1,11 @@
+--- mpfr-2.3.1/mpfr-longlong.h~ 2008-01-01 03:29:09.000000000 +0000
++++ mpfr-2.3.1/mpfr-longlong.h 2008-10-27 21:46:44.000000000 +0000
+@@ -406,7 +406,7 @@
+ "rIJ" ((USItype) (bl)))
+ #endif
+
+-#if defined (__arm__) && W_TYPE_SIZE == 32
++#if defined (__arm__) && W_TYPE_SIZE == 32 && !defined(__thumb__)
+ #define add_ssaaaa(sh, sl, ah, al, bh, bl) \
+ __asm__ ("adds\t%1, %4, %5\n\tadc\t%0, %2, %3" \
+ : "=r" (sh), "=&r" (sl) \
diff --git a/recipes/mpfr/mpfr-canadian_2.3.1.bb b/recipes/mpfr/mpfr-canadian_2.3.1.bb
new file mode 100644
index 0000000000..e35f24eac9
--- /dev/null
+++ b/recipes/mpfr/mpfr-canadian_2.3.1.bb
@@ -0,0 +1,3 @@
+require mpfr_${PV}.bb
+inherit canadian-native
+DEPENDS = "gmp-canadian"
diff --git a/recipes/mpfr/mpfr-native_2.1.1.bb b/recipes/mpfr/mpfr-native_2.1.1.bb
new file mode 100644
index 0000000000..01ba37c8bf
--- /dev/null
+++ b/recipes/mpfr/mpfr-native_2.1.1.bb
@@ -0,0 +1,4 @@
+require mpfr_${PV}.bb
+inherit native
+DEPENDS = "gmp-native"
+
diff --git a/recipes/mpfr/mpfr-native_2.3.1.bb b/recipes/mpfr/mpfr-native_2.3.1.bb
new file mode 100644
index 0000000000..01ba37c8bf
--- /dev/null
+++ b/recipes/mpfr/mpfr-native_2.3.1.bb
@@ -0,0 +1,4 @@
+require mpfr_${PV}.bb
+inherit native
+DEPENDS = "gmp-native"
+
diff --git a/recipes/mpfr/mpfr-native_2.3.2.bb b/recipes/mpfr/mpfr-native_2.3.2.bb
new file mode 100644
index 0000000000..dec26d33a8
--- /dev/null
+++ b/recipes/mpfr/mpfr-native_2.3.2.bb
@@ -0,0 +1,3 @@
+require mpfr_${PV}.bb
+inherit native
+DEPENDS = "gmp-native"
diff --git a/recipes/mpfr/mpfr-native_svn.bb b/recipes/mpfr/mpfr-native_svn.bb
new file mode 100644
index 0000000000..51b0f0a5d5
--- /dev/null
+++ b/recipes/mpfr/mpfr-native_svn.bb
@@ -0,0 +1,3 @@
+require mpfr_svn.bb
+inherit native
+DEPENDS = "gmp-native"
diff --git a/recipes/mpfr/mpfr.inc b/recipes/mpfr/mpfr.inc
new file mode 100644
index 0000000000..cf898b62b6
--- /dev/null
+++ b/recipes/mpfr/mpfr.inc
@@ -0,0 +1,6 @@
+DESCRIPTION = "A C library for multiple-precision floating-point computations with exact rounding"
+HOMEPAGE = "http://www.mpfr.org/"
+LICENSE = "LGPL"
+SECTION = "libs"
+
+inherit autotools
diff --git a/recipes/mpfr/mpfr_2.1.1.bb b/recipes/mpfr/mpfr_2.1.1.bb
new file mode 100644
index 0000000000..1a60ab17a2
--- /dev/null
+++ b/recipes/mpfr/mpfr_2.1.1.bb
@@ -0,0 +1,11 @@
+require mpfr.inc
+
+DEPENDS = "gmp"
+PR = "r3"
+
+SRC_URI = "http://www.mpfr.org/mpfr-${PV}/mpfr-${PV}.tar.bz2"
+S = "${WORKDIR}/mpfr-${PV}"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/mpfr/mpfr_2.3.1.bb b/recipes/mpfr/mpfr_2.3.1.bb
new file mode 100644
index 0000000000..8da9c0e37f
--- /dev/null
+++ b/recipes/mpfr/mpfr_2.3.1.bb
@@ -0,0 +1,12 @@
+require mpfr.inc
+
+DEPENDS = "gmp"
+PR = "r0"
+
+SRC_URI = "http://www.mpfr.org/mpfr-${PV}/mpfr-${PV}.tar.bz2 \
+ file://long-long-thumb.patch;patch=1"
+S = "${WORKDIR}/mpfr-${PV}"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/mpfr/mpfr_2.3.2.bb b/recipes/mpfr/mpfr_2.3.2.bb
new file mode 100644
index 0000000000..2d8cc960f7
--- /dev/null
+++ b/recipes/mpfr/mpfr_2.3.2.bb
@@ -0,0 +1,12 @@
+require mpfr.inc
+
+DEPENDS = "gmp"
+PR = "r0"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://www.mpfr.org/mpfr-${PV}/mpfr-${PV}.tar.bz2"
+S = "${WORKDIR}/mpfr-${PV}"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/mpfr/mpfr_svn.bb b/recipes/mpfr/mpfr_svn.bb
new file mode 100644
index 0000000000..f1e9273a65
--- /dev/null
+++ b/recipes/mpfr/mpfr_svn.bb
@@ -0,0 +1,12 @@
+require mpfr.inc
+
+DEPENDS = "gmp"
+PV = "0.0+svn${SRCDATE}"
+PR = "r3"
+
+SRC_URI = "svn://scm.gforge.inria.fr/svn/mpfr;module=trunk"
+S = "${WORKDIR}/trunk"
+
+do_stage() {
+ autotools_stage_all
+}