aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mysql
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mysql')
-rw-r--r--recipes/mysql/mysql_4.1.22.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/mysql/mysql_4.1.22.bb b/recipes/mysql/mysql_4.1.22.bb
index 5d5900c6d2..7f32b4ddee 100644
--- a/recipes/mysql/mysql_4.1.22.bb
+++ b/recipes/mysql/mysql_4.1.22.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.mysql.com/"
SECTION = "libs"
LICENSE = "GPL"
DEPENDS = "ncurses"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://downloads.mysql.com/archives/mysql-4.1/mysql-${PV}.tar.gz \
file://autofoo.patch;patch=1 \
@@ -40,6 +40,11 @@ do_stage() {
oe_libinstall -a -C libmysqld libmysqld ${STAGING_LIBDIR}
}
+do_stage_append() {
+ sed -i -es,^pkgincludedir=\'/usr/include/mysql\',pkgincludedir=\'\', ${STAGING_BINDIR_CROSS}/mysql_config
+ sed -i -es,^pkglibdir=\'/usr/lib/mysql\',pkglibdir=\'\', ${STAGING_BINDIR_CROSS}/mysql_config
+}
+
do_install() {
oe_runmake 'DESTDIR=${D}' install
mv -f ${D}${libdir}/mysql/* ${D}${libdir}