summaryrefslogtreecommitdiffstats
path: root/recipes/mystun-server/mystun-server_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/mystun-server/mystun-server_cvs.bb')
-rw-r--r--recipes/mystun-server/mystun-server_cvs.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/mystun-server/mystun-server_cvs.bb b/recipes/mystun-server/mystun-server_cvs.bb
new file mode 100644
index 0000000000..09766278b0
--- /dev/null
+++ b/recipes/mystun-server/mystun-server_cvs.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "STUN server used to determine IP behind NAT firewall"
+HOMEPAGE = "http://developer.berlios.de/projects/mystun/"
+SECTION = "console/telephony"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PV = "1:0.0+cvs${SRCDATE}"
+
+SRC_URI="cvs://anonymous@cvs.mystun.berlios.de/cvsroot/mystun;module=mystun \
+ file://init \
+ file://nossl.patch;patch=1"
+
+S = "${WORKDIR}/mystun"
+
+do_compile() {
+ oe_runmake LIBS=-lpthread CFLAGS= server
+}
+
+do_install() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/mystun-server
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/server.exe ${D}${sbindir}/mystun-server
+}