aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nautilus/nautilus_2.24.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nautilus/nautilus_2.24.2.bb')
-rw-r--r--recipes/nautilus/nautilus_2.24.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/nautilus/nautilus_2.24.2.bb b/recipes/nautilus/nautilus_2.24.2.bb
new file mode 100644
index 0000000000..30915b75fc
--- /dev/null
+++ b/recipes/nautilus/nautilus_2.24.2.bb
@@ -0,0 +1,29 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+
+LICENSE="GPL"
+
+PR = "r1"
+
+DEPENDS += " gvfs tracker librsvg libexif eel esound gnome-desktop orbit2-native"
+RDEPENDS = "gvfs"
+
+EXTRA_OECONF = " --disable-gtk-doc --disable-update-mimedb "
+
+PACKAGES += " libnautilus"
+
+FILES_${PN} += "${datadir}/icons /usr/libexec/ "
+FILES_libnautilus = "/usr/lib/*.so*"
+FILES_${PN}-dbg += "/usr/libexec/.debug"
+
+# We need native orbit-idl with target idl files. No way to say it in a clean way:
+do_configure_append () {
+ find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
+}
+
+do_stage() {
+ autotools_stage_all
+}