aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/neon/neon_0.25.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/neon/neon_0.25.5.bb')
-rw-r--r--recipes/neon/neon_0.25.5.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/neon/neon_0.25.5.bb b/recipes/neon/neon_0.25.5.bb
new file mode 100644
index 0000000000..9151a74665
--- /dev/null
+++ b/recipes/neon/neon_0.25.5.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "neon is an HTTP and WebDAV client library, with a C interface."
+HOMEPAGE = "http://www.webdav.org/neon"
+SECTION = "libs"
+LICENSE = "LGPL"
+DEPENDS = "zlib libxml2 expat time gnutls"
+
+PR = "r4"
+
+SRC_URI = "http://www.webdav.org/${PN}/${P}.tar.gz \
+ file://gnutls-force-and-detect.patch;patch=1 \
+ file://gnutls-2.patch;patch=1"
+
+inherit autotools binconfig lib_package pkgconfig
+
+EXTRA_OECONF = "--with-ssl=gnutls --with-libxml2 --with-expat --enable-shared"
+
+do_stage() {
+ autotools_stage_all
+}