summaryrefslogtreecommitdiffstats
path: root/recipes/net-snmp/net-snmp_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/net-snmp/net-snmp_svn.bb')
-rw-r--r--recipes/net-snmp/net-snmp_svn.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/net-snmp/net-snmp_svn.bb b/recipes/net-snmp/net-snmp_svn.bb
new file mode 100644
index 0000000000..2f82865aaa
--- /dev/null
+++ b/recipes/net-snmp/net-snmp_svn.bb
@@ -0,0 +1,27 @@
+require net-snmp.inc
+DEPENDS += "libtool libtool-native libtool-cross"
+
+PR = "r3"
+S = "${WORKDIR}/net-snmp"
+
+SRC_URI = "svn://net-snmp.svn.sourceforge.net/svnroot/net-snmp/trunk;rev=17367;module=net-snmp;proto=https \
+ file://init \
+ file://snmpd.conf \
+ file://snmptrapd.conf"
+
+EXTRA_OECONF = "--enable-shared --disable-manuals --with-defaults \
+ --disable-embedded-perl --with-perl-modules=no GREP=/bin/grep SED=/bin/sed"
+EXTRA_OEMAKE = "INSTALL_PREFIX=${D}"
+
+PARALLEL_MAKE = ""
+CCACHE = ""
+
+do_configure_prepend() {
+ gnu-configize -f
+ # We better change sources and re-autoconf here, but
+ # required autoconf is too new for us.
+ sed -e '/echo.*\".*\\\\.*\"/s/echo/echo -e/g' \
+ -e 's/tail -1/tail -n 1/g' \
+ -i configure
+}
+