aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/neuros-pkggen/neuros-pkggen-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/neuros-pkggen/neuros-pkggen-native.bb')
-rw-r--r--recipes/neuros-pkggen/neuros-pkggen-native.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/neuros-pkggen/neuros-pkggen-native.bb b/recipes/neuros-pkggen/neuros-pkggen-native.bb
new file mode 100644
index 0000000000..13625622d2
--- /dev/null
+++ b/recipes/neuros-pkggen/neuros-pkggen-native.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Tool to generate ready to flash .pkg files for neuros machines"
+LICENSE = "GPLv2"
+PR = "r3"
+
+inherit native
+
+SRC_URI = "file://Makefile \
+ file://Makefile.rules \
+ file://config \
+ file://crc32.c \
+ file://package.c \
+ file://package.h \
+ file://readme \
+ file://zlib.h \
+"
+
+do_compile_prepend() {
+ ( cd ${WORKDIR} ; cp Makefile Makefile.rules config crc32.c package.c package.h readme zlib.h ${S} )
+}
+
+do_stage() {
+ install -m 0755 packet_osd2 ${STAGING_BINDIR_NATIVE}
+}
+
+