summaryrefslogtreecommitdiffstats
path: root/recipes/ngrep
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ngrep')
-rw-r--r--recipes/ngrep/ngrep/use-our-pcre.patch18
-rw-r--r--recipes/ngrep/ngrep_1.42.bb20
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes/ngrep/ngrep/use-our-pcre.patch b/recipes/ngrep/ngrep/use-our-pcre.patch
new file mode 100644
index 0000000000..778c35f196
--- /dev/null
+++ b/recipes/ngrep/ngrep/use-our-pcre.patch
@@ -0,0 +1,18 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- ngrep-1.42/configure.in~use-our-pcre
++++ ngrep-1.42/configure.in
+@@ -134,10 +134,6 @@
+ echo 'Configuring Perl-Compatible Regular Expression (PCRE) library ...'
+ echo
+
+- ( cd pcre-3.4; ./configure && make libtool chartables.c )
+-
+- REGEX_TARGET='pcre'
+- REGEX_OBJS='pcre.o study.o'
+ USE_PCRE="1"
+
+ else
diff --git a/recipes/ngrep/ngrep_1.42.bb b/recipes/ngrep/ngrep_1.42.bb
new file mode 100644
index 0000000000..6f90965860
--- /dev/null
+++ b/recipes/ngrep/ngrep_1.42.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "ngrep strives to provide most of GNU grep's \
+common features, applying them to the network layer."
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "libpcap libpcre"
+LICENSE="ngrep"
+SRC_URI = "${SOURCEFORGE_MIRROR}/ngrep/ngrep-${PV}.tar.bz2 \
+ file://use-our-pcre.patch;patch=1"
+
+EXTRA_OECONF = "--with-restart --enable-pcre --with-pcap-includes=${STAGING_INCDIR}"
+EXTRA_OEMAKE = "INCLUDES=${S}"
+
+inherit autotools
+
+CFLAGS += '-DDROPPRIVS_ONLY_ROOT=0 -DDROPPRIVS_USER=\""nobody\"" -DUSE_DROPPRIVS=1'
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ngrep ${D}${bindir}/
+}