summaryrefslogtreecommitdiffstats
path: root/recipes/nkf
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nkf')
-rw-r--r--recipes/nkf/nkf-native_2.07.bb11
-rw-r--r--recipes/nkf/nkf_2.07.bb13
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes/nkf/nkf-native_2.07.bb b/recipes/nkf/nkf-native_2.07.bb
new file mode 100644
index 0000000000..22bab38deb
--- /dev/null
+++ b/recipes/nkf/nkf-native_2.07.bb
@@ -0,0 +1,11 @@
+require nkf_${PV}.bb
+inherit native
+
+do_stage() {
+ install -m 0755 nkf ${STAGING_BINDIR}
+}
+
+do_install() {
+ :
+}
+
diff --git a/recipes/nkf/nkf_2.07.bb b/recipes/nkf/nkf_2.07.bb
new file mode 100644
index 0000000000..0bce6f20b2
--- /dev/null
+++ b/recipes/nkf/nkf_2.07.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Network Kanji Code Conversion Filter"
+LICENSE = "GPL"
+
+SRC_URI = "http://ftp.debian.org/debian/pool/main/n/nkf/nkf_${PV}.orig.tar.gz"
+S = "${WORKDIR}/nkf207"
+
+EXTRA_OEMAKE = "-e"
+
+do_install() {
+ install -d ${D}${bindir} ${D}${mandir}/man1
+ install -m 0755 nkf ${D}${bindir}
+ install -m 0644 nkf.1 ${D}${mandir}/man1
+}