aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/bogl/bogl-utils-native_0.1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nonworking/bogl/bogl-utils-native_0.1.9.bb')
-rw-r--r--recipes/nonworking/bogl/bogl-utils-native_0.1.9.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/nonworking/bogl/bogl-utils-native_0.1.9.bb b/recipes/nonworking/bogl/bogl-utils-native_0.1.9.bb
new file mode 100644
index 0000000000..94a1d4e00b
--- /dev/null
+++ b/recipes/nonworking/bogl/bogl-utils-native_0.1.9.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Utilities for Ben's Own Graphics Library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "gd-native"
+PR = "2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/b/bogl/bogl_${PV}-${PR}.tar.gz"
+S = "${WORKDIR}/bogl"
+
+inherit native
+
+do_compile() {
+ oe_runmake bdftobogl pngtobogl
+ # giftobogl doesn't work because gd no longer comes with GIF support
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}/
+ install -m 0755 bdftobogl pngtobogl ${STAGING_BINDIR}/
+}