aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/bogl/libbogl_0.1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nonworking/bogl/libbogl_0.1.9.bb')
-rw-r--r--recipes/nonworking/bogl/libbogl_0.1.9.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/nonworking/bogl/libbogl_0.1.9.bb b/recipes/nonworking/bogl/libbogl_0.1.9.bb
new file mode 100644
index 0000000000..db18ee3160
--- /dev/null
+++ b/recipes/nonworking/bogl/libbogl_0.1.9.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Ben's Own Graphics Library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "bogl-utils-native"
+PR = "2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/b/bogl/bogl_${PV}-${PR}.tar.gz"
+S = "${WORKDIR}/bogl"
+
+do_compile() {
+ ln -sf ${STAGING_BINDIR_NATIVE}/bdftobogl .
+ ln -sf ${STAGING_BINDIR_NATIVE}/pngtobogl .
+ oe_runmake libbogl.so.0.1 libbogl.a
+}
+
+do_stage() {
+ oe_soinstall libbogl.so.0.1 ${STAGING_LIBDIR}/
+ install bogl*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_soinstall libbogl.so.0.1 ${STAGING_LIBDIR}/
+}
+