aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/maemo/sapwood_1.20-1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/nonworking/maemo/sapwood_1.20-1.bb')
-rw-r--r--recipes/nonworking/maemo/sapwood_1.20-1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/nonworking/maemo/sapwood_1.20-1.bb b/recipes/nonworking/maemo/sapwood_1.20-1.bb
new file mode 100644
index 0000000000..8cd52fa602
--- /dev/null
+++ b/recipes/nonworking/maemo/sapwood_1.20-1.bb
@@ -0,0 +1,23 @@
+PR = "r1"
+LICENSE = "GPL"
+SECTION = "x11/base"
+DESCRIPTION = "GTK theme engine Sapwood"
+DEPENDS = "gtk+-2.6.4-1.osso7"
+
+FILES_${PN} += "${libdir}/gtk-2.0/2.4.0/engines/"
+
+SRC_URI = "http://stage.maemo.org/pool/maemo/ossw/source/s/${PN}/${PN}_${PV}.tar.gz \
+ file://cflags.patch;patch=1;pnum=0 \
+ file://sockets.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/${PN}-1.20"
+EXTRA_OECONF = "--enable-abstract-sockets=no"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}${sysconfdir}/osso-af-init
+ install -m755 ${S}/debian/sapwood-server.sh ${D}${sysconfdir}/osso-af-init/sapwood-server.sh
+}
+
+