summaryrefslogtreecommitdiffstats
path: root/recipes/omniorb/omniorb-native_4.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/omniorb/omniorb-native_4.0.7.bb')
-rw-r--r--recipes/omniorb/omniorb-native_4.0.7.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/omniorb/omniorb-native_4.0.7.bb b/recipes/omniorb/omniorb-native_4.0.7.bb
new file mode 100644
index 0000000000..1df6236aea
--- /dev/null
+++ b/recipes/omniorb/omniorb-native_4.0.7.bb
@@ -0,0 +1,18 @@
+SECTION = "devel"
+DEPENDS += "python-native"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/omniorb/omniORB-${PV}.tar.gz"
+
+S = "${WORKDIR}/omniORB-${PV}"
+
+inherit native autotools
+
+do_compile () {
+ oe_runmake
+}
+# Ugly hack so libtool does not find native libs when building cross packages
+# We really only build this package for omniidl anyway
+do_stage_append() {
+ rm -f ${STAGING_LIBDIR_NATIVE}/libomni*
+}