aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openbox/openbox_3.4.7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openbox/openbox_3.4.7.2.bb')
-rw-r--r--recipes/openbox/openbox_3.4.7.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/openbox/openbox_3.4.7.2.bb b/recipes/openbox/openbox_3.4.7.2.bb
new file mode 100644
index 0000000000..2b15861e80
--- /dev/null
+++ b/recipes/openbox/openbox_3.4.7.2.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "openbox Window Manager"
+SECTION = "x11/wm"
+DEPENDS = ""
+
+SRC_URI = "http://icculus.org/openbox/releases/openbox-${PV}.tar.gz"
+
+inherit autotools update-alternatives
+
+EXTRA_OECONF += "--with-plugins=none"
+
+PACKAGES += "lxde-icon-theme"
+FILES_${PN} += "${datadir}/lxde/ ${datadir}/lxpanel ${datadir}/xsessions"
+FILES_lxde-icon-theme = "${datadir}/icons"
+
+PACKAGES_DYNAMIC += "${PN}-theme-*"
+
+python populate_packages_prepend() {
+ theme_dir = bb.data.expand('${datadir}/themes/', d)
+ theme_name = bb.data.expand('${PN}-theme-%s', d)
+ do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
+}
+
+ALTERNATIVE_PATH = "${bindir}/openbox"
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PRIORITY = "10"