aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmax
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openmax')
-rw-r--r--recipes/openmax/libomxil-bellagio/0001-configure.ac-remove-Werror-from-CFLAGS.patch32
-rw-r--r--recipes/openmax/libomxil-bellagio_0.9.2.1.bb4
-rw-r--r--recipes/openmax/libomxil-bellagio_git.bb3
3 files changed, 39 insertions, 0 deletions
diff --git a/recipes/openmax/libomxil-bellagio/0001-configure.ac-remove-Werror-from-CFLAGS.patch b/recipes/openmax/libomxil-bellagio/0001-configure.ac-remove-Werror-from-CFLAGS.patch
new file mode 100644
index 0000000000..1df2b262fd
--- /dev/null
+++ b/recipes/openmax/libomxil-bellagio/0001-configure.ac-remove-Werror-from-CFLAGS.patch
@@ -0,0 +1,32 @@
+From 85a2b9666ba2b65920f4ad0e2216405dc14340d4 Mon Sep 17 00:00:00 2001
+From: Paul Menzel <paulepanter@users.sourceforge.net>
+Date: Mon, 17 Jan 2011 23:35:18 +0100
+Subject: [PATCH] configure.ac: remove `-Werror` from `CFLAGS`
+
+These options should be set when compiling the program and passed by an environment variable. Or there should be an option to turn these restrictive options off.
+
+Currently the build fails at least with GCC 4.5. It is known to work with GCC 4.3.3 [1].
+
+[1] http://sourceforge.net/mailarchive/message.php?msg_id=26911808
+
+Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
+---
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index d6e0bc9..fb5c8c8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -5,7 +5,7 @@ AM_INIT_AUTOMAKE()
+ AC_PREREQ([2.59])
+
+ AC_CONFIG_HEADERS([config.h])
+-CFLAGS="${CFLAGS} -Wall -Werror"
++CFLAGS="${CFLAGS} -Wall"
+
+ ################################################################################
+ # Set the shared versioning info, according to section 6.3 of the libtool info #
+--
+1.7.2.3
+
diff --git a/recipes/openmax/libomxil-bellagio_0.9.2.1.bb b/recipes/openmax/libomxil-bellagio_0.9.2.1.bb
index f21c731fcb..89f521af03 100644
--- a/recipes/openmax/libomxil-bellagio_0.9.2.1.bb
+++ b/recipes/openmax/libomxil-bellagio_0.9.2.1.bb
@@ -2,5 +2,9 @@ require ${PN}.inc
PR = "${INC_PR}.0"
+SRC_URI += " \
+ file://0001-configure.ac-remove-Werror-from-CFLAGS.patch \
+"
+
SRC_URI[md5sum] = "323049db668ab260870fd7ecd2ec4156"
SRC_URI[sha256sum] = "75cf8d3b5cac2764420ae2cc7846b9bb12a47d2ca04c96e5821309b0124ddc72"
diff --git a/recipes/openmax/libomxil-bellagio_git.bb b/recipes/openmax/libomxil-bellagio_git.bb
index 4e28251f75..f58adf4d2a 100644
--- a/recipes/openmax/libomxil-bellagio_git.bb
+++ b/recipes/openmax/libomxil-bellagio_git.bb
@@ -4,6 +4,9 @@ PR = "${INC_PR}.0"
SRCREV = "772f0eca88b242ffb5469e8e381c63ce1f7cd3e1"
SRC_URI = "git://omxil.git.sourceforge.net/gitroot/omxil/omxil;protocol=git"
+SRC_URI += " \
+ file://0001-configure.ac-remove-Werror-from-CFLAGS.patch \
+"
PV = "0.9.2.1"
PR = "${INC_PR}.0"
PR_append = "+gitr${SRCPV}"