aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-3rdparty/pisi_0.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openmoko-3rdparty/pisi_0.5.2.bb')
-rw-r--r--recipes/openmoko-3rdparty/pisi_0.5.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/openmoko-3rdparty/pisi_0.5.2.bb b/recipes/openmoko-3rdparty/pisi_0.5.2.bb
new file mode 100644
index 0000000000..b7249912d0
--- /dev/null
+++ b/recipes/openmoko-3rdparty/pisi_0.5.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "PISI is synchronizing information"
+AUTHOR = "Michael Pilgermann"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://freshmeat.net/projects/pisiom"
+SRCNAME = "pisi"
+DEPENDS = "python-native"
+RDEPENDS = "python-vobject python-core python-pygtk python-pygobject python-pycairo\
+ python-gdata python-webdav python-ldap python-epydoc python-core\
+ python-dateutil python-sqlite3 python-netserver python-netclient\
+ python-misc python-ctypes libsyncml"
+
+PACKAGE_ARCH = "all"
+
+SRC_URI = "http://github.com/downloads/kichkasch/pisi/pisi-src-${PV}.tar.gz"
+SRC_URI[md5sum] = "ea947696e99db19b61893c43b47609f6"
+SRC_URI[sha256sum] = "58e0411cdc7b7c18a5276b10dc3b5261193a5c2f4c79c45ab0c91bdd7d351b28"
+
+FILES_${PN} += "/opt/${PN} \
+ ${datadir}/pixmaps \
+ ${datadir}/applications \
+ ${datadir}/doc/${PN}"
+CONFFILES_${PN} += "/usr/share/doc/${PN}/conf.example"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/python ${S}/setup.py build ${D}
+}
+
+do_install() {
+ ${STAGING_BINDIR_NATIVE}/python ${S}/setup.py install ${D}
+ rm -rf ${D}/opt/pisi/build/
+ rm -rf ${D}/opt/pisi/patches/
+}