aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb')
-rw-r--r--recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb b/recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb
new file mode 100644
index 0000000000..0961d74162
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Standard Gtk+ icon theme for the Openmoko distribution"
+SECTION = "openmoko/base"
+PV = "0.1+svnr${SRCREV}"
+PR = "r1"
+
+inherit openmoko-base autotools
+
+SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/artwork;module=icons;proto=http"
+S = "${WORKDIR}/icons"
+
+pkg_postinst_openmoko-icon-theme-standard () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+gtk-update-icon-cache ${datadir}/icons/openmoko-standard/
+}
+
+PACKAGE_ARCH = "all"