aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-projects/openmoko-community-repository.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openmoko-projects/openmoko-community-repository.bb')
-rw-r--r--recipes/openmoko-projects/openmoko-community-repository.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/openmoko-projects/openmoko-community-repository.bb b/recipes/openmoko-projects/openmoko-community-repository.bb
new file mode 100644
index 0000000000..8486309a34
--- /dev/null
+++ b/recipes/openmoko-projects/openmoko-community-repository.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Configuration files for online package repositories of the Openmoko community repository feeds."
+PR = "r0.03"
+
+do_compile() {
+ mkdir -p ${S}/${sysconfdir}/opkg
+ for feed in Multiverse; do
+ echo "src/gz daily-${feed} ${OPENMOKO_URI}/${feed}" > ${S}/${sysconfdir}/opkg/${feed}-feed.conf
+ done
+}
+do_install () {
+ install -d ${D}${sysconfdir}/opkg
+ install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+CONFFILES_${PN} += "${sysconfdir}/opkg/Multiverse-feed.conf"
+
+OPENMOKO_URI = "http://downloads.openmoko.org/repository"