aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opensync/libopensync_0.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opensync/libopensync_0.20.bb')
-rw-r--r--recipes/opensync/libopensync_0.20.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/opensync/libopensync_0.20.bb b/recipes/opensync/libopensync_0.20.bb
new file mode 100644
index 0000000000..9560e5f949
--- /dev/null
+++ b/recipes/opensync/libopensync_0.20.bb
@@ -0,0 +1,18 @@
+LICENSE = "LGPL"
+HOMEPAGE = "http://www.opensync.org/"
+
+DEPENDS = "sqlite3 libxml2 zlib glib-2.0"
+
+SRC_URI = "http://www.openembedded.org/sources/libopensync-${PV}.tar.gz"
+
+inherit autotools pkgconfig lib_package
+
+EXTRA_OECONF = "--disable-python"
+LEAD_SONAME = "libopensync.so"
+
+FILES_${PN} += " ${libdir}/opensync/formats/*.so"
+
+do_stage() {
+autotools_stage_all
+}
+