summaryrefslogtreecommitdiffstats
path: root/recipes/opie-examples-python
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opie-examples-python')
-rw-r--r--recipes/opie-examples-python/opie-examples-python.inc27
-rw-r--r--recipes/opie-examples-python/opie-examples-python_1.2.2.bb6
-rw-r--r--recipes/opie-examples-python/opie-examples-python_1.2.3.bb6
-rw-r--r--recipes/opie-examples-python/opie-examples-python_1.2.4.bb6
-rw-r--r--recipes/opie-examples-python/opie-examples-python_cvs.bb7
5 files changed, 52 insertions, 0 deletions
diff --git a/recipes/opie-examples-python/opie-examples-python.inc b/recipes/opie-examples-python/opie-examples-python.inc
new file mode 100644
index 0000000000..10ba40afdf
--- /dev/null
+++ b/recipes/opie-examples-python/opie-examples-python.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "Python examples for Opie"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python-pyqt opie-pyquicklaunchapplet"
+APPNAME = "python"
+PACKAGE_ARCH = "all"
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+do_configure() {
+ :
+}
+
+do_compile() {
+ :
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin/python/ ${D}${palmtopdir}/apps/Python
+ install -m 0755 *.py ${D}${palmtopdir}/bin/python/
+ install -m 0644 ${WORKDIR}/apps/Python/.directory ${D}${palmtopdir}/apps/Python/
+ install -m 0644 ${WORKDIR}/apps/Python/simple.desktop ${D}${palmtopdir}/apps/Python/
+}
+
diff --git a/recipes/opie-examples-python/opie-examples-python_1.2.2.bb b/recipes/opie-examples-python/opie-examples-python_1.2.2.bb
new file mode 100644
index 0000000000..f9349e3364
--- /dev/null
+++ b/recipes/opie-examples-python/opie-examples-python_1.2.2.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/examples/python \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
diff --git a/recipes/opie-examples-python/opie-examples-python_1.2.3.bb b/recipes/opie-examples-python/opie-examples-python_1.2.3.bb
new file mode 100644
index 0000000000..f9349e3364
--- /dev/null
+++ b/recipes/opie-examples-python/opie-examples-python_1.2.3.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/examples/python \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
diff --git a/recipes/opie-examples-python/opie-examples-python_1.2.4.bb b/recipes/opie-examples-python/opie-examples-python_1.2.4.bb
new file mode 100644
index 0000000000..f9349e3364
--- /dev/null
+++ b/recipes/opie-examples-python/opie-examples-python_1.2.4.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/examples/python \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
diff --git a/recipes/opie-examples-python/opie-examples-python_cvs.bb b/recipes/opie-examples-python/opie-examples-python_cvs.bb
new file mode 100644
index 0000000000..8caf26238c
--- /dev/null
+++ b/recipes/opie-examples-python/opie-examples-python_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_CVS_PV}"
+
+SRC_URI = "${HANDHELDS_CVS};module=opie/examples/python \
+ ${HANDHELDS_CVS};module=opie/pics \
+ ${HANDHELDS_CVS};module=opie/apps"