summaryrefslogtreecommitdiffstats
path: root/recipes/opkg/opkg-nogpg-nocurl-slugos_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opkg/opkg-nogpg-nocurl-slugos_svn.bb')
-rw-r--r--recipes/opkg/opkg-nogpg-nocurl-slugos_svn.bb29
1 files changed, 20 insertions, 9 deletions
diff --git a/recipes/opkg/opkg-nogpg-nocurl-slugos_svn.bb b/recipes/opkg/opkg-nogpg-nocurl-slugos_svn.bb
index cac02fd4cc..d39e6cee7f 100644
--- a/recipes/opkg/opkg-nogpg-nocurl-slugos_svn.bb
+++ b/recipes/opkg/opkg-nogpg-nocurl-slugos_svn.bb
@@ -2,7 +2,7 @@
# recipe, intended for temporary use by the SlugOS distro.
# DO NOT USE this recipe for anything other than SlugOS and svn version 160
-# of the opkg sources. Also note that This recipe will be removed without
+# of the opkg sources. Also note that this recipe will be removed without
# notice when the unfortunate commits to the original opkg-nogpg-nocurl_svn.bb
# recipe are repaired, the small-memory patches updated to a newer opkg svn
# version, and appropriate testing confirms that the resulting binary actually
@@ -10,12 +10,23 @@
# DO NOT CHANGE THIS RECIPE!
-require opkg.inc
+DESCRIPTION = "Opkg Package Manager"
+DESCRIPTION_libopkg = "Opkg Package Manager Library"
+SECTION = "base"
+LICENSE = "GPLv2"
+SRCREV = "160"
+PV = "0.1.6+svnr${SRCPV}"
+PR = "r22"
-DEPENDS = ""
PROVIDES += "opkg"
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
SRC_URI += " \
+ svn://opkg.googlecode.com/svn;module=trunk;proto=http \
+ file://opkg_unarchive.patch;maxrev=201 \
+ file://opkg-intercept-cleanup.patch;maxrev=241 \
file://isatty.patch \
file://opkg_wget.patch;maxrev=180 \
file://reduce-nogpg-noise.patch;maxrev=180 \
@@ -23,11 +34,16 @@ SRC_URI += " \
file://opkg_wget_nogpg_02_use_vfork_system.patch \
file://opkg_wget_nogpg_03_fix_tmpdirs.patch \
file://opkg_wget_nogpg_04_default_tmpdir.patch \
+ file://configure \
"
-PR = "${INC_PR}"
EXTRA_OECONF += "--disable-gpg --enable-static --disable-shared"
+do_install_prepend() {
+ install -d ${D}${sysconfdir}/rcS.d
+ install -m 0755 ${WORKDIR}/configure ${D}${sysconfdir}/rcS.d/S98configure
+}
+
# Not sure this is needed; needs to be investigated and removed if not
# The nogpg version isn't getting much love and has an unused variable which trips up -Werror
@@ -41,11 +57,6 @@ FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
# not happens automatically for opkg-nogpg:
FILES_${PN} += "${datadir}/opkg/intercept"
-# Define a variable to allow distros to run configure earlier.
-# (for example, to enable loading of ethernet kernel modules before networking starts)
-OPKG_INIT_POSITION = "98"
-OPKG_INIT_POSITION_slugos = "41"
-
pkg_postinst_${PN} () {
update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
}