aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opkg')
-rw-r--r--recipes/opkg/files/configure18
-rw-r--r--recipes/opkg/opkg-nogpg_svn.bb2
-rw-r--r--recipes/opkg/opkg_svn.bb26
3 files changed, 29 insertions, 17 deletions
diff --git a/recipes/opkg/files/configure b/recipes/opkg/files/configure
new file mode 100644
index 0000000000..1a8c3149b5
--- /dev/null
+++ b/recipes/opkg/files/configure
@@ -0,0 +1,18 @@
+#!/bin/sh
+# get splash funcs
+if [ -f /etc/default/splashfuncs ]; then
+ . /etc/default/splashfuncs
+fi
+## tell boot status to "pulsate" really long busy cycle here
+status_pulse || true
+# run configure in bg
+opkg-cl configure &
+PID=$!
+# while configure still running loop
+while test -d /proc/$PID; do
+# tick to splash so it doesn't time out
+ status_tick || true
+ sleep 1
+done
+# delete myself
+rm -f /etc/rcS.d/S98configure
diff --git a/recipes/opkg/opkg-nogpg_svn.bb b/recipes/opkg/opkg-nogpg_svn.bb
index a9297d7645..641c7be451 100644
--- a/recipes/opkg/opkg-nogpg_svn.bb
+++ b/recipes/opkg/opkg-nogpg_svn.bb
@@ -3,7 +3,7 @@ require opkg_svn.bb
DEPENDS = "curl"
PROVIDES += "opkg"
-PR = "r3"
+PR = "r11"
SRCREV = "${SRCREV_pn-opkg}"
diff --git a/recipes/opkg/opkg_svn.bb b/recipes/opkg/opkg_svn.bb
index a4728970ce..bc9af61dce 100644
--- a/recipes/opkg/opkg_svn.bb
+++ b/recipes/opkg/opkg_svn.bb
@@ -1,6 +1,6 @@
require opkg.inc
-PR = "r2"
+PR = "r11"
PACKAGES =+ "libopkg-dev libopkg"
@@ -12,23 +12,17 @@ FILES_libopkg = "${libdir}/*.so.*"
OPKG_INIT_POSITION = "98"
OPKG_INIT_POSITION_slugos = "41"
+SRC_URI += "file://configure"
+
+do_install_prepend() {
+ install -d ${D}${sysconfdir}/rcS.d
+ install -m 0755 ${WORKDIR}/configure ${D}${sysconfdir}/rcS.d/S98configure
+}
+
pkg_postinst_${PN} () {
-#!/bin/sh
-if [ "x$D" != "x" ]; then
- install -d $D${sysconfdir}/rcS.d
- # this happens at S98 where our good 'ole packages script used to run
- echo "#!/bin/sh
-opkg-cl configure
-rm -f ${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
-" > $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
- chmod 0755 $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
-fi
-
-update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
+ update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
}
pkg_postrm_${PN} () {
-#!/bin/sh
-update-alternatives --remove opkg ${bindir}/opkg-cl
+ update-alternatives --remove opkg ${bindir}/opkg-cl
}
-