aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pad/pad-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pad/pad-native.bb')
-rw-r--r--recipes/pad/pad-native.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes/pad/pad-native.bb b/recipes/pad/pad-native.bb
index e8c2b6d579..cc1f7aa405 100644
--- a/recipes/pad/pad-native.bb
+++ b/recipes/pad/pad-native.bb
@@ -3,6 +3,7 @@ DESCRIPTION = "Console utility for padding a file (filling with 0 to reach a spe
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/pad"
SRC_URI = "file://pad.c"
LICENSE = "PD"
+PR = "r1"
inherit native
do_compile() {
@@ -10,6 +11,9 @@ do_compile() {
${CC} -I. -o pad pad.c
}
-do_stage() {
- install -m 0755 pad ${STAGING_BINDIR}/
+do_install() {
+ install -d ${D}${bindir}/
+ install -m 0755 pad ${D}${bindir}/
}
+
+NATIVE_INSTALL_WORKS = "1"