aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/patcher
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/patcher')
-rw-r--r--recipes/patcher/files/freebsd_gpatch.patch28
-rw-r--r--recipes/patcher/patcher-native_20040913.bb20
-rw-r--r--recipes/patcher/patcher_20040913.bb15
3 files changed, 63 insertions, 0 deletions
diff --git a/recipes/patcher/files/freebsd_gpatch.patch b/recipes/patcher/files/freebsd_gpatch.patch
new file mode 100644
index 0000000000..ee6365f49d
--- /dev/null
+++ b/recipes/patcher/files/freebsd_gpatch.patch
@@ -0,0 +1,28 @@
+On FreeBSD the default patch program has a different command line
+interface than GNU patch. Make patcher use the GNU patch.
+
+
+--- patcher/patcher.py.old Mon Sep 13 21:59:05 2004
++++ patcher/patcher.py Sun Jul 17 14:24:50 2005
+@@ -631,8 +631,8 @@
+ my $res;
+
+ # ... then we look if the patch would apply cleanly ...
+- print "DEBUG: patch --dry-run $opt\n" if $debug > 1;
+- $res = system("patch --dry-run $opt >$patchlog 2>/dev/null");
++ print "DEBUG: gpatch --dry-run $opt\n" if $debug > 1;
++ $res = system("gpatch --dry-run $opt >$patchlog 2>/dev/null");
+ if ($res != 0) {
+ unless ($do_force) {
+ unlink($patchlog);
+@@ -669,8 +669,8 @@
+ # Finally we apply the patch. No need to create backup copies with -b,
+ # that has been done by PutIntoPatch()
+ $opt = "-f $opt" if $do_force;
+- print "DEBUG: patch $opt\n" if $debug > 1;
+- $res = system("patch $opt >$patchlog");
++ print "DEBUG: gpatch $opt\n" if $debug > 1;
++ $res = system("gpatch $opt >$patchlog");
+ unlink($patchlog);
+ $res = 0 if $do_force && $res == 256;
+ if ($res != 0) {
diff --git a/recipes/patcher/patcher-native_20040913.bb b/recipes/patcher/patcher-native_20040913.bb
new file mode 100644
index 0000000000..c071d52404
--- /dev/null
+++ b/recipes/patcher/patcher-native_20040913.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Patcher is a perl script for managing patches."
+HOMEPAGE = "http://www.holgerschurig.de/patcher.html"
+LICENSE = "Perl"
+DEPENDS = ""
+SECTION = "base"
+PRIORITY = "optional"
+PACKAGES = ""
+PR = "r1"
+
+inherit native
+
+SRC_URI = "http://www.holgerschurig.de/files/linux/patcher-${PV}.tar.bz2"
+SRC_URI_append_build-freebsd = " file://freebsd_gpatch.patch;patch=1 "
+S = "${WORKDIR}/patcher"
+
+PATCHTOOL = "patch"
+
+do_stage() {
+ install -m 0755 patcher.py ${STAGING_BINDIR}/patcher
+}
diff --git a/recipes/patcher/patcher_20040913.bb b/recipes/patcher/patcher_20040913.bb
new file mode 100644
index 0000000000..471f75af7b
--- /dev/null
+++ b/recipes/patcher/patcher_20040913.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Patcher is a perl script for managing patches."
+HOMEPAGE = "http://www.holgerschurig.de/patcher.html"
+LICENSE = "Perl"
+DEPENDS = ""
+SECTION = "base"
+PRIORITY = "optional"
+INHIBIT_DEFAULT_DEPS = "1"
+
+SRC_URI = "http://www.holgerschurig.de/files/linux/patcher-${PV}.tar.bz2"
+S="${WORKDIR}/patcher"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 patcher.py ${D}${bindir}/patcher
+}