aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pbltool
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pbltool')
-rw-r--r--recipes/pbltool/pbltool-native_0.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/pbltool/pbltool-native_0.2.bb b/recipes/pbltool/pbltool-native_0.2.bb
new file mode 100644
index 0000000000..7b2d80acf0
--- /dev/null
+++ b/recipes/pbltool/pbltool-native_0.2.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Loader tool for Amstrad Delta (E3)"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://the.earth.li/pub/e3/pbltool-${PV}.c"
+
+INHIBIT_NATIVE_STAGE_INSTALL = "1"
+
+do_compile() {
+ ${CC} -o pbltool ${WORKDIR}/pbltool-${PV}.c
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 pbltool ${DEPLOY_DIR_IMAGE}
+}
+
+addtask deploy before do_build after do_compile
+
+inherit native